1991 Chevy 2500 starting problem

Discussion in 'Chevy Truck Forum' started by CowboyCadilac, Jun 8, 2011.

  1. CowboyCadilac

    CowboyCadilac Full Member

    Joined:
    Jun 8, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    I have a 1991 Chevy k2500 with a 5.7 tbi. It just happened the other day where the truck just shut off like I turned the key off. Then finally got it running and it ran fine for a couple days and then happened again. Had it towed home and today put a new fuel pump and fuel pump relay and got it to start 2 times but then died and now won't start again. Does anyone have any idea where to go next?
     
  2. kronhenry

    kronhenry Senior Member

    Joined:
    Apr 21, 2011
    Messages:
    211
    Likes Received:
    15
    Trophy Points:
    0
    Occupation:
    Welder
    Location:
    Tennessee
    did you replace the fuel filter
     
  3. CowboyCadilac

    CowboyCadilac Full Member

    Joined:
    Jun 8, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    I did not replace the fuel filter. Wasn't exactually sure if the fuel filter could cause it to do that? It also when u turn the key is not shooting gas out of the injectors. So I guess maybe it could be a plugged fuel filter.
     
  4. kronhenry

    kronhenry Senior Member

    Joined:
    Apr 21, 2011
    Messages:
    211
    Likes Received:
    15
    Trophy Points:
    0
    Occupation:
    Welder
    Location:
    Tennessee
    or it could be the icm check to see if you have spark. the icm controls the injectors and the spark and they love to fail
     
  5. CowboyCadilac

    CowboyCadilac Full Member

    Joined:
    Jun 8, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    I bought a fuel filter for it today. Don't have time yet to get it put in so will post after I get it put in tomorrow. Thanks for all the help. Forgot to ad that I did go out today after it sat all night and tried starting it and it started right up. Ran for about 30 secs and then just like I turned the key off and died and wouldn't start again.
     
  6. kronhenry

    kronhenry Senior Member

    Joined:
    Apr 21, 2011
    Messages:
    211
    Likes Received:
    15
    Trophy Points:
    0
    Occupation:
    Welder
    Location:
    Tennessee
    try unplugging the temp sensor and starting it. its located next to the top radiator hose on the manifold
     
  7. CowboyCadilac

    CowboyCadilac Full Member

    Joined:
    Jun 8, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    Got the new fuel filter in tonight. Started up after priming the pump a few times. Ran for about 30 secs and died again and wouldn't start back up. Waited about 5 min and it started again and did the same thing over. Now it won't start again. Tried umpluging the temp sensor and starting it and still didn't start. So is my next option to replace ICM?
     
  8. kronhenry

    kronhenry Senior Member

    Joined:
    Apr 21, 2011
    Messages:
    211
    Likes Received:
    15
    Trophy Points:
    0
    Occupation:
    Welder
    Location:
    Tennessee
    try testing the pressure at the tbi i think it should be between 12-16 psi if you get good pressure and it still doent put out from the injectors my next thought would be icm there pretty cheap
     
  9. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,209
    Likes Received:
    12,802
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    When it will not start pour some fuel in throttle body.... if still no crank check for spark at the plugs... then at coil.
    If not probably be icm or pickup coil. Check resistance on the icm and pickup.
    If you get 800 to 1200 ohms of resistance they are good.
    The pickup is a old school / type of crank sensor.
     
  10. CowboyCadilac

    CowboyCadilac Full Member

    Joined:
    Jun 8, 2011
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    Ok so I bought the ICM today and not sure how to put it in or where it goes. Can anyone give me a heads up on how to install it?
     

Share This Page