1994 k1500 - help ...no brake lights

Discussion in 'Chevy Truck Forum' started by duramac, Jan 31, 2008.

  1. duramac

    duramac New Member

    Joined:
    Jan 31, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    #1 duramac, Jan 31, 2008
    Last edited by a moderator: Mar 26, 2011
    94 1500 4x4 just pulled truck into shop ,no brake lights,,both left and right turn signals work fine.blew a fuse when turning on 4 way hazard lights, change fuse and still no brake lights,,where do i satrt with this one?
    if turn signals are working then the bulbs are ok.the fuse it blows is the stop hazard fuse think its number 1 in the fuse box,maybe a short or brake light switch?
     
  2. junior3382

    junior3382 Senior Member

    Joined:
    Mar 8, 2007
    Messages:
    3,171
    Likes Received:
    88
    Trophy Points:
    0
    Occupation:
    Used vehicle salesman, JEEPS mostly
    Location:
    Currently, I live in Lancaster county, Pennsylvani
    Home Page:
    Do the parking lights work along with the turn signals and 4-ways?
     
  3. 436'd skylark

    436'd skylark Senior Member

    Joined:
    Mar 8, 2007
    Messages:
    1,143
    Likes Received:
    27
    Trophy Points:
    0
    Occupation:
    Mac Tool Distributor
    Location:
    Pennsyltucky
    multi-function switch...
     
  4. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    Trophy Points:
    0
    Welcome to the forum duramac.
    You are right on the bulbs being ok. Thought the stop fuse was bottom center.
    Pull the hazard flasher out (not turn flasher), replace the 15A fuse.
    Verify turn signals work. Check that fuse does not blow and high stop light works.
    If not I would suspect you have water in your high stop lamp fixture.
    If it does work, bad haz flasher or turn/haz combo switch as Joe suggested.
    Or something in the wiring connecting them shorting (brown wire)
     
  5. brandoj

    brandoj New Member

    Joined:
    May 15, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    Field service engineer
    Location:
    Oregon
    My 94 Silerado had the same problem. I believe It was a recall back in the day. Brake switch under dash near the brake pedal OR check yer wiring harness at rear end. I "accidently" bolted a hitch to my harness and created a short there.
     
  6. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    Trophy Points:
    0
    I believe the recall was for "wrong polarity" on the wiring to switch and the possible hazard was fire. Should work fine until that point.
     
  7. 340doc

    340doc Full Member

    Joined:
    Jan 30, 2008
    Messages:
    27
    Likes Received:
    1
    Trophy Points:
    0
    My 97 has a fuse box under the hood also ,with another brake light fuse.
     
  8. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    Trophy Points:
    0
    94's didn't have fancy underhood fuse boxes LOL Only fuse there was fuel pump.
     

Share This Page