1999 Suburban Backup / Reverse Lights Not Working

Discussion in 'Chevy Truck Forum' started by tde, Oct 26, 2011.

  1. tde

    tde New Member

    Joined:
    Oct 26, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    When I shift into reverse, the corresponding lights do not turn on. Thinking maybe they were burned out, I replaced them but still no dice.

    I checked the driver side dashboard fuse panel as well, all fuses are fine. Turn signals, brake lights, etc all work fine...it's just the backup lights.

    My next guess is a bad wire or circuit board, but I'm not sure where to look.

    I'm a novice, but if any experienced people out there tell me where to look I can probably take care of it as I'm pretty good with my hands.

    Thanks in advance!

    TD
    '99 K1500 Suburban 4x4
     
  2. Case 7230

    Case 7230 Senior Member

    Joined:
    Dec 15, 2007
    Messages:
    1,645
    Likes Received:
    53
    Trophy Points:
    0
    #2 Case 7230, Oct 26, 2011
    Last edited: Oct 26, 2011
    It is unlikely that both bulbs would be bad but worth checking them. Not an expert but if I had to guess I would say that the neutral safety switch is bad. I would think (not 100% sure) that the NSS is at the bottom of the steering column near the floorboards.
    Hopefully some of the experts will give an opinion soon.
     
  3. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,210
    Likes Received:
    12,806
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    What case has said .. also could be circuit board .. had a lot of flaws in it.
     

Share This Page