2003 Tahoe with post warm up rough idle

Discussion in 'Chevy Truck Forum' started by ksllb, Nov 26, 2011.

  1. ksllb

    ksllb Member

    Joined:
    Nov 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Guys this is getting frustrating. I have a 2003 Tahoe 5.3 flex fuel that started off throwing a code for MAF 10 weeks ago. I cleaned the MAF and reset the code without issue. One month later light came on and the code was for lean left and lean right. At this time it began to idle very rough a couple minutes after start up. Five to ten minutes of run time and the rough idle would go away. Mechanic changed fuel filter prior to a trip I was making. The next day the light came back on. I changed the forward O2 sensors in an Autozone parking lot and still no relief. Next I changed the plugs and wires. No help. The codes had now expanded to include random misfire and possible purge valve solenoid. I changed the purge valve solenoid and MAF and reset. Today at start up it still idled very rough a couple minutes after start up. I drove it and the light came back on. Checked and the codes were for lean left and lean right. Right back where I started. It was noted today that the idle was at 540 rpm.

    At this point it seems that the problem is a low idle. At start up it runs fine. After a couple minutes it runs rough. After it warms up more, it runs fine. If I hold the rpm up during the rough idle, it runs fine.

    Today it was recommended that I look at the catalytic converters and vacuum lines. I am feeling a little lost. I read on an old post that these symptoms could be due to a leaking intake, clogged EGR valve, dirty throttle body or bad idle air control valve.

    Thanks in advance for any help.
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,210
    Likes Received:
    12,809
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Random misfire ... lean bank 1 lean bank 2 hard to diagnose these. 03 would not think cat. Seems if it was a vac leak would idle a little fast.
    What type of air filter? Will think on this .
     
  3. ksllb

    ksllb Member

    Joined:
    Nov 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Just running a Fram filter. It seems crazy that it runs so perfect after that initial warm up period.
     
  4. ksllb

    ksllb Member

    Joined:
    Nov 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    It does have 127k on it.
     
  5. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,210
    Likes Received:
    12,809
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Do this make sure all is tight down stream of maf... any air leak will create probs.
    Have you changed fuel filter... check fuel pressure at least 58 psi and hold.
    Lean condition air fuel ratio off more air than fuel. Go ahead and check for vacuum leaks ... will not get any better response from a certified mech.
    Theses are hard to diagnose. Could have a live scan done on it.
     
  6. ksllb

    ksllb Member

    Joined:
    Nov 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Fuel filter has been changed. I will check for air leaks down stream, the fuel pressure and for vacuum leaks next. Thanks for the help. I have done a lot of change and hope so far.
     
  7. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,210
    Likes Received:
    12,809
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    More i think about it intake gasket maybe leaking... will do this on start up.. then when engine gets warm will close off some.
    Due to heat expansion.
     
  8. repairman54

    repairman54 Senior Member

    Joined:
    Jun 21, 2010
    Messages:
    62
    Likes Received:
    2
    Trophy Points:
    0
    Occupation:
    serv. tech
    Location:
    Montague, NJ
    Engine temp sensor may be off at the lower temps and close enough after it warms up.
    My sisters Malibu eats them......
     
  9. ksllb

    ksllb Member

    Joined:
    Nov 26, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I see........
     

Share This Page