94 chevy silverado

Discussion in 'Chevy Truck Forum' started by jman1973, Jun 9, 2008.

  1. jman1973

    jman1973 Full Member

    Joined:
    Jun 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    hey guys new here
    i have a 94 silverado with a 350
    around 1100-1500 rpms the engine seems as if its starved for fuel
    if i let off the gas or give it gas it goes away
    ive changed the fuel filter the fuel injectors on the TBI and replaced the diaphram new cap and rotor plugs and wires
    im lost to the problem
    the map and tps sensors both tested good
    it does it in park or under a load
    any help would be appreciated
     
  2. junior3382

    junior3382 Senior Member

    Joined:
    Mar 8, 2007
    Messages:
    3,171
    Likes Received:
    88
    Trophy Points:
    0
    Occupation:
    Used vehicle salesman, JEEPS mostly
    Location:
    Currently, I live in Lancaster county, Pennsylvani
    Home Page:
    you tested the sensors and replaced filters.... is the computer communicating? I mean any codes to speak of?

    Now when you say it is starved for fuel, you sure it is not starved for air? Perhaps the MAP sensor could be testing fine, but there is still a blockage not allowing the proper air flow for your engine to breath properly.
     
  3. jman1973

    jman1973 Full Member

    Joined:
    Jun 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    the check engine light is off
    i unhooked the vacuum from the map sensor and it sets the check engine light off right away
     
  4. jman1973

    jman1973 Full Member

    Joined:
    Jun 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    i also took the EGR valve off and it was very clean
    was going to time time it but i cant find the bypass for manual mode
     
  5. Case 7230

    Case 7230 Senior Member

    Joined:
    Dec 15, 2007
    Messages:
    1,645
    Likes Received:
    53
    Trophy Points:
    0
    Does this happen with engine both hot and cold?
     
  6. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,877
    Likes Received:
    6,957
    Trophy Points:
    113
    Location:
    N.Y.
    hook it to a good scan tool and make sure the tps is giving a good signal. Parts at the bottom range of specs give problems but don't set codes.
     
  7. wojeepster

    wojeepster Senior Member

    Joined:
    Nov 18, 2005
    Messages:
    92
    Likes Received:
    5
    Trophy Points:
    0
    Leave the tps connected with key on. Using an analog(needle) or bargraph digital measure tps signal wire to ground should be .5v at tickover and go smoothy up all the way to wot at 4.5v as you open the throttle any 'dead' spots signal a bad tps. With a plain digital you cannot tell anything.
     
  8. jman1973

    jman1973 Full Member

    Joined:
    Jun 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    happens both hot and cold
    just sputters if i hold the throttle there
    if i let it go it almost dies but dont
    idle is fine
    if i give it more gas it goes away as well
     
  9. Case 7230

    Case 7230 Senior Member

    Joined:
    Dec 15, 2007
    Messages:
    1,645
    Likes Received:
    53
    Trophy Points:
    0
    The reason I asked was I had the same idea as wojeepster. I thought you maybe had the TPS checked cold but the problem only occured hot. It does sound like a faulty TPS but if it checks out OK it can`t be. Pull the vacuum pipe off of the EGR valve, plug it and see if that makes any difference.
     
  10. jman1973

    jman1973 Full Member

    Joined:
    Jun 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    i pulled the vacuum from the EGR and it lopes
    plugged it off and the problem is still there
    it sets off the check engine light too
     

Share This Page