loss oil pressure and antifreeze 2004 5.3L silverado

Discussion in 'Chevy Truck Forum' started by Bob Trem, Jan 21, 2012.

  1. Bob Trem

    Bob Trem New Member

    Joined:
    Jan 21, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have a 2004 Silverado 5.3L with 154,000 that has 2 maybe 3 problems and wonder if they could possibly be related to a single cause.
    1. I have an intermittent loss of oil pressure. The pressure as one would expect is dependent on the rpm when rpm is 1000 or greater there is no engine knock when the rpm drops to under 700 the pressure drops to the point where the engine starts to knock. The problem self corrects lasting about 8000miles (2 oil changes) only to return. This has happened 3 times now.
    2. There is a cold start tapping that lasts from a few seconds to 2 or 3 mins.
    3. The antifreeze disappears at the rate of 1 gal per 3000 miles. There are no apparent leaks, oil appears normal, and no noticeable exhaust changes.

    Other than these issues the truck runs great getting about 18 miles per gal. Any suggestion?
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,206
    Likes Received:
    12,795
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Need to do a pressure check on cooling system. Sure coolant is not getting in oil ...causing the other problem with pressure and knock.
    Coolant going somewhere if not on ground ..out the exhaust ..or oil ..or both.
     
  3. dirtrider73068

    dirtrider73068 Moderator
    Staff Member

    Joined:
    Jul 14, 2011
    Messages:
    5,871
    Likes Received:
    3,327
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    dump trucker driver
    Location:
    Central Oklahoma
    I would top of the coolant drive it the 300o miles, checking oil ever so often see if oil level goes up if it does your getting coolant in the oil somehow. If its doing that the oil should be turing a brown or milky white.
     
  4. Bob Trem

    Bob Trem New Member

    Joined:
    Jan 21, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the ideas. The oil always looks good, the truck uses about 1 qt of oil in 2500 miles. I will do A PRESSURE CHECK for the antifreeze loss problem. Having low oil pressure which returns to normal remains a mystry to me. I am thinking the oil and antifreeze problems must not be related if there is no sign of antifreeze in the oil.
     
  5. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,864
    Likes Received:
    6,928
    Trophy Points:
    113
    Location:
    N.Y.
    oil pressure could be a pump problem, the relief valve may be sticking in the pump.....coolant....how do the spark plugs look? pressure test to 18#'s and look hard!
     

Share This Page