Modulator valve on my turbo 400....

Discussion in 'GMC Truck Forum' started by 86longandwide, Dec 3, 2011.

  1. 86longandwide

    86longandwide New Member

    Joined:
    Dec 3, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi everybody!

    I need some mechanical help here. I just bought a 1986 GMC Sierra 1500. It has a 4.3 Liter V6 with a turbo 400 transmission. Odd huh? The engine is out of a van I'm thinking because the oil filler cap is extended to the front of the motor.
    Anyways the transmisson is having a hard time shifting between gears. It won't shift until I'm at high RPM. I changed the filter and fluid in the transmission, also changed the modulator valve. I followed the vacuum line back to the motor where it goes into the intake manifold. It splits off from there two directions, one goes behind the motor over on the other side of the power booster to what appears to be an emissions box or something. The other heads towards the front of the motor but it has been cut off and capped with a screw. Alot of my vacuum lines and emissions have been removed. Any suggestions or thoughts would be greatly appreciated. I'm new with vacuum lines and emissions but i'm learning there importance. I want my truck to shift properly also.
    Thanks Alot!
    Gabriel
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,206
    Likes Received:
    12,795
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
  3. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,206
    Likes Received:
    12,795
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Just like oldmech said in his post.. all you really need is a vacuum to distributor .. brake booster ,and modulator valve.
    Rest of it is emissions .
     
  4. dirtrider73068

    dirtrider73068 Moderator
    Staff Member

    Joined:
    Jul 14, 2011
    Messages:
    5,871
    Likes Received:
    3,327
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    dump trucker driver
    Location:
    Central Oklahoma
    I would try to pull that T off that line for the tranny, hook the modulator vacuum line up by its self drive it see if it shifts better, it could be its losing some its vacuum needed to work right. When you start T'ing vacuum lines you lose vacuum each time its split.
     

Share This Page