still have harsh shifting problem on my 93

Discussion in 'Chevy Truck Forum' started by 93bluesilverrad, Mar 31, 2013.

  1. 93bluesilverrad

    93bluesilverrad Full Member

    Joined:
    Dec 29, 2007
    Messages:
    403
    Likes Received:
    124
    Trophy Points:
    43
    93 1500, 5.7, 4L60E...harsh shifting from park to reverse and drive, sometimes on 1-2 shift, rest are ok. history: truck went into trans shop due to free reving rpm increase on mild acceleration onto freeway in I blieve 3rd gear...all solenoid replaced--three times, no joy. finally shop replaced ecm with OEM brand from autozone and that problem went away......now came the harsh shifting issues so all solenoids were changed, three different times, I saw valve body down twice and still no joy. I myself replaced a broke temp sensor on top of intake, broke vac line of some type that went to the MAP ( not sure when or how these were damaged) and finally the TPS which seemed to significantly help the harsh shifts EXCEPT for the park to reverse and drive and this is intermittent and most noticable when truck has been turned off and sits. example going thru fast food drive thru and turning off truck and putting into park for couple minutes or when starting after work or overnight. Help.....could the ecm be defective or is it one or all of solenoids or ?????????? thanks for advice.
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,209
    Likes Received:
    12,802
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
  3. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,871
    Likes Received:
    6,951
    Trophy Points:
    113
    Location:
    N.Y.
    i would check the tps, number 26, seen it on my 90
     
  4. dirtrider73068

    dirtrider73068 Moderator
    Staff Member

    Joined:
    Jul 14, 2011
    Messages:
    5,875
    Likes Received:
    3,329
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    dump trucker driver
    Location:
    Central Oklahoma
    Need to check the grounds, make sure they have good clean tight contact, and check wires make sure none are rubbing or shorting out, but if that happens should get a check engine light if it shorts out a sensor.
     
  5. 93bluesilverrad

    93bluesilverrad Full Member

    Joined:
    Dec 29, 2007
    Messages:
    403
    Likes Received:
    124
    Trophy Points:
    43
    new tps, grounds cleaned and tight, no bad wires etc. so I am at loss
     
  6. gpmorgan

    gpmorgan Auto Banned

    Joined:
    Nov 21, 2009
    Messages:
    2,687
    Likes Received:
    287
    Trophy Points:
    0
    Occupation:
    forklifts and equip tech
    Location:
    Tupelo Ms.
    Might need to check the servo. I'm not a trans man but I'm pretty sure it has something to do with shift pressures.
     
  7. 93bluesilverrad

    93bluesilverrad Full Member

    Joined:
    Dec 29, 2007
    Messages:
    403
    Likes Received:
    124
    Trophy Points:
    43
    all solenoids/servos changed before, 90% of time still get harsh shift from park into reverse or drive, quick but firm on other shifts except 40% or so the 1-2 shift is harsh.....still searching for some kind of solution as trans shop can't figure it out.:( I am afraid a hard part will brake and on top of that it is really annoying and ticks me off.
     

Share This Page