Truck will not idle correctly

Discussion in 'Ford Truck Forum' started by KyJIM, Sep 7, 2011.

  1. KyJIM

    KyJIM Member

    Joined:
    Jun 28, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    My 97 Ford F150 with a 4.6 litre will not idle in gear properly it idles just fine in park . I replaced both Ignition coils because they were the original Ford factory part ,Truck has almost 172,000 on it ..Just wonder if oxygen sensors would cause my problem. Plugs and wires seem to be ok . I was troubleshooting out of Haynes manual . Any thoughts out there . The truck also has a new Maf sensor .
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,209
    Likes Received:
    12,802
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Are you getting service engine light? I would do a good tune up ... plugs &wires fuel filter ect. Probably running a little rough in park also.. when you put in gear put a little pressure on engine notice it more. If you have no service light will not be 02,s ect. Could try cleaning the maf.
     
  3. zombie1969

    zombie1969 Senior Member

    Joined:
    Jun 30, 2010
    Messages:
    1,016
    Likes Received:
    16
    Trophy Points:
    0
    Location:
    CT
    Clean the throttle body also.Get some carb clean a tooth brush a rag and go to town.Make sure you get around the blade real good.
     
  4. tjzz4

    tjzz4 Senior Member

    Joined:
    Oct 5, 2007
    Messages:
    459
    Likes Received:
    29
    Trophy Points:
    0
    Could be IAC
     
  5. KyJIM

    KyJIM Member

    Joined:
    Jun 28, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Ok thanks i will look into the things suggested .
     
  6. KyJIM

    KyJIM Member

    Joined:
    Jun 28, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Oh yea the check engine light was on but i took the negative battery cable off and reset it , it went out drove it hasnt came back on yet .
     
  7. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,209
    Likes Received:
    12,802
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Run truck till code comes back scan.. will lead you in right direction.
     
  8. KyJIM

    KyJIM Member

    Joined:
    Jun 28, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Ford F-150

    Its a plug wire issue cylinder 5 some moisture on the wire where i didnt drive it alot i assume .. The car parts place call for just Bosch spark plug . I am thinking autolites have to be just as good ..
     
  9. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,209
    Likes Received:
    12,802
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Auto lite better than bosch.
     

Share This Page