Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: electrical problems 89 chevy

  1. #1
    Junior Member
    Join Date
    Apr 2008
    Posts
    6

    Question electrical problems 89 chevy

    HELP ! having electical problems i have a 89 half ton silverrado 2wheel dr . i just installed a eng and trans form a 1993 truck also changed the wiring harness under the hood and behind the dash .with a friends help so far my altenator looked like it had a smoke bomb lit inside of it and my pos battery cable melted i can only get 1st gear when i put in drive and i then manully shift it to 2nd gear for 2nd and thats it no drive or overdrive , could someone give some advice on maybe what is going on it seems to me that there are to many wires connected to the battery juntion box on the firewall also there are several wires cut and spliced in this area. i desperatly need a wiring diagram i have not yet connected the red wire to the altenator . and are there any circuts ,relays,trans kickdown, devices that i need with the 93 ,that 89 doesnt have.also there is a small relay?to the left of battery juntion box that has a pink/bk and tan/wht and a black wire comeing out that is connected pnk/bk to a gray wire the tan/wht to another gray wire coming out of the harness and bk to bk that cant be right
    Last edited by dwayne; 04-03-2008 at 04:35 PM. Reason: i need help very soon i am missing work

  2. #2
    Senior Member keithr0005005's Avatar
    Join Date
    Jan 2008
    Posts
    156
    just a hunch but an 89 has a 700r4 trans and the 93 has a 4l60e? are you aware that the 4l60 is computer controlled and wont function without it?

  3. #3
    Junior Member
    Join Date
    Apr 2008
    Posts
    6

    89 to 93

    Quote Originally Posted by keithr0005005 View Post
    just a hunch but an 89 has a 700r4 trans and the 93 has a 4l60e? are you aware that the 4l60 is computer controlled and wont function without it?
    i also installed the compurter box behind the glovebox that came with the 93 harness didnt know it was a electroic controlled trans is that good or bad no let me guess . so thats why it wont shift correctly even when manuely shifting any ideas

  4. #4
    Junior Member
    Join Date
    Apr 2008
    Posts
    6
    i also replaced the computer box behind the the glovebox is that the computer that controls the transmission i hope if i an lucky enough to have one thing go right where do i go from here any ideas and no i didnt know it was a computer controlled i dont know if i am asking questions in the right places or not so you my see me writing all over the place

  5. #5
    Senior Member
    crabtruck's Avatar
    Join Date
    Jul 2007
    Posts
    5,566
    Welcome to the forum dwayne
    It would be a help to know which eng,tranny and ignition (HEI or DI) you're using.
    This may or may not help you ...presuming A/T





  6. #6
    Junior Member
    Join Date
    Apr 2008
    Posts
    6
    the diagram does help thankyou ,I have now pretty much solved my transmission problems but i still have a problem i not been able to solve maybe you can help one thing i do need a wiring diagram for 1993 chevy silverado 1/2 ton 2 wheel drive .What i am having problems with is my alternator when i connect the red wire and the dark brown wire to the back of the alternator it sounds as if it is being overloaded and when i drive down the road it misses and will even die and will not start untill i disconnect the wires from the back of the altenator also when i connect the wires to the alternator the fuel gauge drops to empty ? I have a new battery ,altenator, and starter solenoid so it will charge but the truck runs terrible i afraid to run it hooked up for fear it is going to cause more problems. so i only drive the truck during the day off the battery

  7. #7
    Senior Member Chevy_Finatic79's Avatar
    Join Date
    Mar 2008
    Location
    Lincoln NE
    Posts
    494

    Here's a general Diagram from 88-98 helped me out a bunch

    "She's gonna Freak when she see's my wheels"

    85' Chevy C-10 Longbox (Rat)
    TBI 327 Cu.In./THM350

    90' Chevy Suburban 4x4
    TBI 350 Cu.In./700R4

    http://www.truckforum.org/forums/truck-pictures-176.htm

  8. #8
    Senior Member Chevy_Finatic79's Avatar
    Join Date
    Mar 2008
    Location
    Lincoln NE
    Posts
    494
    Did you check your fuseable link for the altenator that starts at that junction box?
    Also check out my thread (fuel injectors not pulsing either) there are some more diagrams but they are for a 94 which is pretty much the same except for some minor details. the altenator circuit is not a big one should be easy to narrow down
    "She's gonna Freak when she see's my wheels"

    85' Chevy C-10 Longbox (Rat)
    TBI 327 Cu.In./THM350

    90' Chevy Suburban 4x4
    TBI 350 Cu.In./700R4

    http://www.truckforum.org/forums/truck-pictures-176.htm

  9. #9
    Senior Member
    crabtruck's Avatar
    Join Date
    Jul 2007
    Posts
    5,566
    Broken into two problems, gauage and alt, should not be just one error, but maybe.
    Gauge going to empty can be caused by short of sender wire to ground or open in hot to gauge.
    Unless you redid the IP as well during this mod, I think it's losing power at fuse.
    BTW, there are several different wiring styles depending on which eng and tranny.

    For the alt, the brown wire is basically just a tattletail, generally for idiot light.
    It needs a protective diode in it if NB2 style. Might want to leave off temp.
    If your 83 IP has a gauge you basically don't need it.

    The red(s) coming off the alt/battery/battery junction block/starter are
    going to have to be mapped by you at this point, we can't see them.
    Endless ways you could have them, so what's wrong is hard to guess.
    Get out your pencil and paper, and follow them around.
    If you don't want to make yourself crazy while doing that, pre-draw
    the alt/battery/battery junction block/starter and two boxes for the firewall connectors,
    around a sheet of paper. Then play connect the dots, flagging each wire with duct tape as you draw it.
    Note your fusible links, could be as many as 9, in every about wire except maybe the batt-starter one.
    Something like this fake drawing...


    You might want to confirm that the PCM,harness and eng are a match for use.
    Also it is important to know which eng,tranny combo is being used since connections vary.
    Will also help other folks working on similar mods

  10. #10
    Junior Member
    Join Date
    Apr 2008
    Posts
    6
    thanks chevy fanatic and crabtruck for the diagrams and your helpful response . the eng and trans info which i should have mentioned before is a 1989 1/2 ton chevy silverado ext cab 2 wheel drive with a 1993 wire harness under the hood and behind the dash including computor ,gauges,fuse box,etc the 350 and 4l60e automatic transmission is all out of the same 1993 truck

Page 1 of 2 12 LastLast

Similar Threads

  1. 98 chevy s10 starter/electrical problems.
    By timmus_buckus in forum Chevy Truck Forum
    Replies: 1
    Last Post: 02-07-2008, 12:10 AM
  2. electrical problems
    By robert d in forum GMC Truck Forum
    Replies: 4
    Last Post: 11-19-2007, 05:55 PM
  3. 85 chevy truck electrical problems
    By joe cottom in forum Chevy Truck Forum
    Replies: 13
    Last Post: 10-25-2007, 11:17 PM
  4. 1994 Chevy pickup electrical problems
    By seniorjudge in forum Chevy Truck Forum
    Replies: 4
    Last Post: 01-02-2007, 08:17 AM
  5. 1994 chevy truck electrical problems
    By ohio larry in forum Chevy Truck Forum
    Replies: 0
    Last Post: 12-25-2005, 10:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •