Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 2001 Suburban AC Problem

  1. #1
    Junior Member
    Join Date
    Sep 2008
    Posts
    6

    2001 Suburban AC Problem

    The AC stopped working on my '01 Suburban. Looking for help in troubleshooting. Can I get some help to locate the low pressure switch? Planning on jumpering this switch and if the compressor runs then adding freon. Can I just purchase a kit and add freon? Any help with the next steps is appreciated.

  2. #2
    Senior Member
    Join Date
    Aug 2008
    Location
    williamsburg virginia
    Posts
    305
    was the ac working good before it stopped? if so you might want to buy a can of 134-a and a charge hose {with a gauge on it}. the low cut out should be on your accumalator.first,check ac fuse,start truck and turn ac on full blast,see it compressor kicks on,or does it cycle on and off,if so jump out cut out switch to see it compressor kicks on,hook the can a gauge up to check pressure.add freon as needed.

  3. #3
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,158
    if the compressor comes up and shuts right back down, then you are more than likely low on freon. if the switch has gone faulty, than you wont have any action or the compressor will stay running.

  4. #4
    Senior Member
    leolkfrm's Avatar
    Join Date
    Mar 2008
    Location
    N.Y.
    Posts
    8,411
    is climatic control? if so you will need to disconnect the battery to reset it. the switchis on the dryer on the firewall
    4 wheels move the body
    2 wheels move the soul
    B.W.A.I
    Snow is a lot like religion and a lot like sex....you never know when you are going to get it!....or how much you will get

  5. #5
    Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Thank you for the help. Located the switch. It is cooler here in MD now and the AC was working yesterday. The temperature was about 70 ve 90 last weekend.

    Tried to hook gauges to it to get the low pressure and high pressure readings. The only two locations that I could find for the gauges were on the same line. One on each side of a hose connection (not sure if there was an orifice inside the connection and as a result I was reading the pressures on both sides of the orifice). Anyway the two connections fit the gauge (I am aware that the connections on the gauge are sized so you can't mix hp and lp up). The pressure on the high side was 150 and the low side was 75 - 105. With these readings I don't think I was on the correct low side port. I searched all the AC lines and can't locate another port to connect to. I was expecting the high pressure to be 200+ and the low pressure to be in the 30 - 45 range.

    I could post pictures if that would help with the troubleshooting.

  6. #6
    Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Name:  HPIM3585.jpg
Views: 1874
Size:  79.9 KB

    Name:  HPIM3584.jpg
Views: 1420
Size:  56.7 KB

    Tried to post some pictures

  7. #7
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,158
    high pressure will go above 200 on a warmer day. same as your low side. should not be above 100 ever and should max out at around 75 on that same day. are you reading the same scale on the guages?? on the manifolds, you should have a reading in PSI and then another bar for r134. the bar marked 134 you are going to want under 40 and over 25 at least. there should be another port besides those two.

  8. #8
    Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Looked at my gauges again and I was reading the wrong scale. Will check again. Still don't think that I am on the correct ports.

  9. #9
    Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Can someone please confirm that these are the right connections to put the AC gauges including putting the freon on the one on the low side.

  10. #10
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,158
    burban, there should be another port somewhere. look back around the ac compressor somewhere. your low side is going to be located somewhere on that larger pipe.

Page 1 of 2 12 LastLast

Similar Threads

  1. 2001 Ford Supercrew problem
    By icunurse47557 in forum Ford Truck Forum
    Replies: 3
    Last Post: 03-31-2008, 03:22 PM
  2. 2001 Suburban oil leak help
    By DesertCraw4th in forum Chevy Truck Forum
    Replies: 1
    Last Post: 04-25-2007, 05:59 AM
  3. 2001 Chevy Silverado Z-71 Starting Problem
    By a5150joseph in forum Chevy Truck Forum
    Replies: 1
    Last Post: 12-03-2006, 08:11 PM
  4. Paint Problem, 2001 Dakota
    By Tokie in forum Dodge Truck Forum
    Replies: 0
    Last Post: 09-16-2006, 04:32 AM
  5. 2001 GMC 2500 Cruise Control Problem
    By jim5434 in forum GMC Truck Forum
    Replies: 1
    Last Post: 07-18-2006, 12:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •