Results 1 to 4 of 4

Thread: 97 Chevy c2500 w/5.7 vortec hesitating in morning

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Posts
    3

    Question 97 Chevy c2500 w/5.7 vortec hesitating in morning

    Just recently about 1 month ago I noticed that when I get in my truck in the morning and start it up it runs at idle fine but if I give the truck some gas in park and bring the rpm up to 2,000 it starts to hesitate/miss when I take off to drive it as you give it gas it hesitates/misses the truck still accelerates to 55 mph an drives but jerks while driving, when i take off from a stop and floor it, it doesnt hesitate after the truck warms up and i drive it arround town a little bit it runs fine no hesitation no missing nothing runs perfect, I replaced the fuel filter so i know its not that, I put a new cap and rotor on in mid oct. 2009 1 year replacement parts, new wires the same day limited life time warrenty, and pcv valve also on same day, and bosh platnium plugs on same day, I pulled the plugs out and they look good, I took the cap off to inspect cap and rotor, the rotor looked fine and the cap had some whiteness to the pionts, i dont know what to do except another tune-up i havent replace the air filter in a while but it looked great i know its not starving for air but im still going to replace it, I bought all these parts from advance should i just pull them of and make them replace them or what i dont know what to do someone please help.
    Thank Joe

  2. #2
    Senior Member
    Join Date
    Mar 2007
    Posts
    139
    i would have used all delco parts on the tuneup. That may be something you want to try, seams these old chevys like delco parts best.
    also add a can of seaform to the next couple of tanks of fuel this will help clean the fuel system.

    I had my 2000 model 2500 series with 350 engine tuned up at 90K because I planned to make a trip pulling our travel trailer, but the old truck was running fine before the tuneup 90K miles.

    Truck still runs great.

    might also check your shocks when you get the running issue taken care of.

    my shocks at 90K were completely dead, new shocks made a difference in ride

  3. #3
    Junior Member
    Join Date
    May 2010
    Posts
    6
    Quote Originally Posted by maddragster View Post
    Just recently about 1 month ago I noticed that when I get in my truck in the morning and start it up it runs at idle fine but if I give the truck some gas in park and bring the rpm up to 2,000 it starts to hesitate/miss when I take off to drive it as you give it gas it hesitates/misses the truck still accelerates to 55 mph an drives but jerks while driving, when i take off from a stop and floor it, it doesnt hesitate after the truck warms up and i drive it arround town a little bit it runs fine no hesitation no missing nothing runs perfect, I replaced the fuel filter so i know its not that, I put a new cap and rotor on in mid oct. 2009 1 year replacement parts, new wires the same day limited life time warrenty, and pcv valve also on same day, and bosh platnium plugs on same day, I pulled the plugs out and they look good, I took the cap off to inspect cap and rotor, the rotor looked fine and the cap had some whiteness to the pionts, i dont know what to do except another tune-up i havent replace the air filter in a while but it looked great i know its not starving for air but im still going to replace it, I bought all these parts from advance should i just pull them of and make them replace them or what i dont know what to do someone please help.
    Thank Joe
    2 things to check on,first it could be the catalytic converter is beginning to stop up.its common for an older vehicle like yours,they can do a pressure test to see if it is or not.they drill a hole in front of the converter and a hole in back of the converter.any muffler shop can do this for you,then they just weld the holes back up.

    the other thing it could be is the mass air flow sensor.this is what went out on my 98 chevy3500 and it was doing the same thing you described.try to unplug it and see if it makes a difference on how it runs or not.its a pretty expensive sensor to replace,but i put a new one on my truck and it runs like a scalded cat now.good luck-spark

    also,run about a half can of seafoam in the engine and see if this helps,it will help even if it doesnt solve the problem.the best way to get the foam in the engine is thru the pcv valve.let it suck it up thru the pcv valve and it will clean out the vaccuum lines and hoses.the truck will smoke quite a bit after you start it back up but this is normal.its burning off the old oil and junk that the seafoam had cleaned out of the lines.then pour the rest of the bottle in the gas tank.good luck-spark

  4. #4
    Full Member
    Join Date
    Aug 2009
    Posts
    19
    Pull out your distributor, go to autozone and get a gear for it, and a punch. Knock out the retaining pin. Put a new gear on it. Hammer the pin back in.. I think this will fix yer problem. What I think is going on is your distributor gear is worn. Your computer controls your timing. When the gear is worn there is slack in it. (take yer cap off and see if there is any play in the rotor there should be NONE) If there is play in your rotor the truck wont be able to time itself unless you are decelerating or accelerating and the truck will stumble. Also make sure the holes in the bottom of your distributor are clear, these distributors have a hard time dissapating moisture and your cap problem sounds like one I once had. From the discription of your problem. I can pretty much promise the gear thing will work. If you are not that mechanicly inclined. you can get a new or rebuil distributor from autozone..

Similar Threads

  1. 98 chevy c2500 350 5.7 lectricals cut in and out
    By maddragster in forum Chevy Truck Forum
    Replies: 3
    Last Post: 04-17-2010, 05:37 PM
  2. New to me '98 Chevy C2500 75,000 miles
    By CharlyG in forum Chevy Truck Forum
    Replies: 33
    Last Post: 05-23-2009, 07:29 PM
  3. 1991 Chevy C2500 4x2 brake problems
    By skyline2250 in forum Chevy Truck Forum
    Replies: 10
    Last Post: 05-20-2009, 03:49 PM
  4. 1991 Chevy C2500 Ignition Control Module
    By skyline2250 in forum Truck Classifieds
    Replies: 0
    Last Post: 05-18-2009, 10:42 AM
  5. 88 Chevy c2500 700 R4 shift problem
    By billk in forum Chevy Truck Forum
    Replies: 3
    Last Post: 07-02-2008, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •