Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: 1994 Chevy K1500 idles rough and stalls occasionally

  1. #11
    Full Member diceman1994's Avatar
    Join Date
    Jul 2010
    Location
    Florida
    Posts
    16
    Reference my earlier entry we found that the EGR was operating incorrectly through its' signal switch. It has been running just fine since the tiny hose has been disconnected from the EGR. I was puzzled since after cleaning the TBI and tuning it up the truck ran better but still lacked power and sounded like it was running on 6 cylinders. Lesson learned, same thing happened 10 years ago on my 84 Bronco.

  2. #12
    Full Member
    Join Date
    Jul 2010
    Location
    Champaign, IL
    Posts
    13
    If you had the distributor out of the truck, and just replaced it with a calibrated eye, the timing needs to be set on it. Minor adjustments in timing can yield major performance changes.

  3. #13
    Junior Member
    Join Date
    Jul 2010
    Location
    Jasper, AL
    Posts
    14
    could be a fuel filter and if not, its worth replacing anyway

  4. #14
    Junior Member
    Join Date
    Nov 2010
    Posts
    1

    Question

    Have a 1993 Chevy Silverado k1500 it runs fine when it is cold, but when it warms up it loses power and has abit of a hesitation, we tuned it up, replaced fuel filter, O2 sensor is new, used gas and fuel injector cleaner, not sure what it could be, we were thinking it could be the sock filter in the gas tank, because he had trouble with his car at one time, it would start fine but would stall while driving he'd wait a second and it would fire back up with no problem, he and different mechanics checked it out and couldn't figure out what the problem was, til one mechanic decided to try and blow the fuel filter sock in the tank off after he popped it off the car ran like nothing was wrong with it for years. the truck doesn't stall, but once in awhile it feels like it might. was told it could be a few other things does anyone have any ideas?

  5. #15
    Senior Member Jaimeson's Avatar
    Join Date
    Aug 2009
    Location
    Biloxi, MS
    Posts
    226
    OP, I apologize if you did already as I only scanned through this thread but pulling the dist seems a bit extreme for a rough idle. Of course it could be the culprit but there are many other things to consider first. Process elimination and ease. Did you check the plugs for fouling or improper gap as well as overall condition and mileage/age? I would also check the EGR valve with a mighty vac as well as the solenoid that controls it. Check the EGR with vacuum and the solenoid with vacuum as well as voltage as it's electronically signaled and then controlled via vacuum. A TM such as Haynes will tell you exactly how to test it. You can get a mighty vac from harbor freight for around $40 and it's a good tool to have on hand for all kinds of other stuff as well as bleeding brakes.

    Alternatively, I would check the timing as well. Own a timing light? Hope this helps and GL finding and fixing the problem.
    93' CHEVROLET SILVERADO BUILT C1500

  6. #16
    Senior Member
    crabtruck's Avatar
    Join Date
    Jul 2007
    Posts
    5,566
    Caution - this thread has multiple trucks, problems, posters.

    Mainly it is kinda stale and a new thread might have been a good idea.
    that way the newest truck in the collection can get it's own consideration.

    Welcome to the forum jadawolf.
    Don't be shy, start a new thread.
    Best part is they're FREE
    No rule says you have to though.

  7. #17
    Senior Member Jaimeson's Avatar
    Join Date
    Aug 2009
    Location
    Biloxi, MS
    Posts
    226
    X2 ^ This why I stated "OP"
    93' CHEVROLET SILVERADO BUILT C1500

  8. #18
    Senior Member
    crabtruck's Avatar
    Join Date
    Jul 2007
    Posts
    5,566
    I caught that, sometimes it's like sorting a puzzle in these threads.

  9. #19
    Full Member
    Join Date
    Jun 2011
    Posts
    10
    I know this is an old post but my recent experience might help somebody. My 90 C150 was doing the same thing. Rough idle on start up and running smooth when warm with the with the odd unexplained stall. I pulled the EGR valve of to check it (it was good) and noticed it wasn't all that tight and the gasket was diong almost nothing to seal it. I cleaned it up with a wire wheel and installed a new gasket that I had lying around and it starts and runs like a dream now. It took about 15 minutes and cost me nothing to do, but what a difference! Hope this helps someone.

  10. #20
    Junior Member
    Join Date
    Jun 2011
    Posts
    1
    Thanks to all joining here as a new member.Basically what's happening is if the truck idle's for a long period of time (traffic jam) it will start to sputter and shake then stall out (idles a little rough too). I can usually get it started back up without a problem 4 or 5 times in a row, then after that it will die completely. I usually have to wait 30min or so before i can start it again. Its only my views.

    delray nissan

Page 2 of 2 FirstFirst 12

Similar Threads

  1. 1994 Chevy K1500 4x4 running irraticaly, HELP!
    By jessicalynn in forum Chevy Truck Forum
    Replies: 21
    Last Post: 12-15-2010, 09:17 PM
  2. 90 K1500 5.7 Stalls in reverse
    By MScan in forum Chevy Truck Forum
    Replies: 11
    Last Post: 10-23-2008, 11:45 AM
  3. 1999 1500 idles rough in morning
    By duckle1 in forum Chevy Truck Forum
    Replies: 5
    Last Post: 02-24-2008, 05:00 PM
  4. Engine idles,rough?
    By pumba in forum Chevy Truck Forum
    Replies: 3
    Last Post: 01-06-2008, 12:15 AM
  5. 94 Sierra Idles Rough
    By Jswerve in forum GMC Truck Forum
    Replies: 12
    Last Post: 02-15-2007, 01:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •