Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 1994 chevy cheyenne 1500 4.3 vortec - no start, ocassional backfire

  1. #1
    Junior Member
    Join Date
    Jan 2011
    Posts
    5

    Post 1994 chevy cheyenne 1500 4.3 vortec - no start, ocassional backfire

    Hi. I have a 1994 chevy cheyenne 1500 4.3 vortec.
    it started running rough a while back at normal speeds it would act like a miss.
    but most times it felt like the old cars & trucks did when the points would stick.
    when i would come to a stop or slow roll at red lights and stop signs
    it would get real bad and almost die and sometimes it would.
    as long as i was on the interstae running 75 or 80 it would run better
    than any car or truck i had ever had...

    about a month ago i was backing out of a parking spot when the truck jumped and then died.
    then when i would try to start it after a few minutes of cranking it would back fire
    which normally i thought timing. had it towed. checked the timing and it is right.
    the distributor had a crack in it so i replaced it and it still wouldn't crank
    just keep backfiring every now and then.

    i checked the spark and all plugs are getting spark.
    it is getting fuel to the throttle bottle but cant check the running pressure since it wont start.
    the check engine light never did come on so i would take it there is no code in the computer?
    any help would be greatly appreciated
    Last edited by crabtruck; 04-22-2011 at 12:21 AM. Reason: title

  2. #2
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,214
    Blog Entries
    2
    Is yours a port fuel injection , or throttle body? 94 had both just checking for more info. Either way need to check fuel pressure 60 to 64 psi port injection, 9 to 14 psi throttle body. You can check pressure with out truck running if your fuel pump works. Let us know on what type injection you have.
    And welcome to the site ACE.

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    Thanks Chevy...... it is throttle body. I thought their were 2 different readings for the fuel pressure but since it doesnt have to be running then the pressure is 12 psi with the switch on

  4. #4
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,214
    Blog Entries
    2
    Ok . Can you pour fuel down throttle body , and see if it runs . You said you had spark at plugs so that rules electrical out.
    I tell almost everyone this check or change temp sensor 10 bucks . This little sensor can have all sorts of symptoms , Change it, get it out of the equation.
    Most times will not bring up a code it is first in line for the ecu. Go from here see what happens.
    DISCONNECT BATTERY BEFORE CHANGING ANY SENSOR.

  5. #5
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    I'll try the gas in the tb. i didnt figure i would have to do that since the injector is putting a good stream into it already. & it's backfiring....... which is another thing that lead me to the timing issue, couldn't figure out why it would be building up enough gas to backfire when all plugs have good spark. it really stumped me when the timing was correct. but anything can happen with the electronic engines i guess. i've always owned carburated engines until this one. so it's like day and night to me. I'll try it and hopefully it will start. if it does what could be the problem?

  6. #6
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,214
    Blog Entries
    2
    Your getting fuel , spark at plugs, You say it is in time. What is your timing set at? How did you check for spark.
    Strange .

  7. #7
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    took off the blanacer pulley. removed the timing chain cover and checked the marks, they line up. their is no slack in the chain either. took plugs out but left them in the wires while my wife turned it over and every plug had spark. rotor button is good and has a brand new dist. cap on it, thats what has me puzzled. I'm completely lost on it. i guess it would have to be one of the sensors so i'll change the temp sensor and go from their like you suggested

  8. #8
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,214
    Blog Entries
    2
    Heck give it a try . It is the one one intake beside thermostat , not sending unit. Going to have me thinking all night lol

  9. #9
    Full Member
    Join Date
    Jan 2011
    Posts
    14
    I don't know how many miles your truck has on it so I will assume that your roller valve train and timing components are 100%

    If you suspect fuel delivery issues on any vehicle get a can of choke cleaner with a spray straw then mist it into any one of the air cleaner suction hoses while cranking (don't start spraying until someone else is cranking with a slightly opened throttle, go easy with controlled bursts until you get the hang of it) . The carb/choke cleaner burns as well as gas and is a lot safer to use.

    If you have a timing light laying around you can connect to any plug wire as normally done then shine the strobe onto the TBI injectors while cranking (or if it will run at times) to see the injector pulsed gas spray pattern. Each time the chosen cylinder fires it will trick your eyes into seeing a freeze frame much as your fan blade appears still while timing older vehicles. Nice fan spray pattern, good injectors and adequate fuel pressure.

    Often overlooked, check your EGR valve to make sure it doesn't open when it shouldn't. You can touch the underside of the valve's rubber bellows (or use a mirror) when not running, have someone crank the vehicle while looking to see if the vacuum operated diaphragm pulls open. If it does, test the EGR vacuum switching valve input signal from the ECM with your DVOM.

    Can anyone tell me where to get the best deal on fender extensions or wheel surrounds and decent pocketed floor mats for my 95 K1500 Sierra? It seems that the aftermarket accessory vendors have abandoned all of the older trucks.

  10. #10
    Full Member
    Join Date
    Jan 2011
    Posts
    14
    Block off your EGR valve with a hand made gasket just for kicks then see what happens.

Page 1 of 2 12 LastLast

Similar Threads

  1. 2011 Chevy Silverado 1500 Cheyenne Edition Help?
    By Burnt Ice2011 in forum Chevy Truck Forum
    Replies: 1
    Last Post: 11-29-2010, 03:46 PM
  2. 2011 Chevy Silverado 1500 Cheyenne Edition Help?
    By Burnt Ice2011 in forum 4x4 trucks / off road
    Replies: 0
    Last Post: 11-29-2010, 10:51 AM
  3. 1994 Chevy 1500 ground problem
    By Xxnhojjohnxx in forum Chevy Truck Forum
    Replies: 1
    Last Post: 08-23-2010, 04:19 PM
  4. 1994 heater/AC 1500 chevy
    By Teepler916 in forum Chevy Truck Forum
    Replies: 3
    Last Post: 04-12-2010, 04:21 PM
  5. 1994 chevy blazer 4.3 vortec
    By bortzman4 in forum Chevy Truck Forum
    Replies: 5
    Last Post: 10-01-2009, 01:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •