Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 1991 Chevy 2500 starting problem

  1. #1
    Full Member CowboyCadilac's Avatar
    Join Date
    Jun 2011
    Location
    Minnesota
    Posts
    23

    1991 Chevy 2500 starting problem

    I have a 1991 Chevy k2500 with a 5.7 tbi. It just happened the other day where the truck just shut off like I turned the key off. Then finally got it running and it ran fine for a couple days and then happened again. Had it towed home and today put a new fuel pump and fuel pump relay and got it to start 2 times but then died and now won't start again. Does anyone have any idea where to go next?

  2. #2
    Senior Member
    Join Date
    Apr 2011
    Location
    Tennessee
    Posts
    211
    did you replace the fuel filter

  3. #3
    Full Member CowboyCadilac's Avatar
    Join Date
    Jun 2011
    Location
    Minnesota
    Posts
    23
    I did not replace the fuel filter. Wasn't exactually sure if the fuel filter could cause it to do that? It also when u turn the key is not shooting gas out of the injectors. So I guess maybe it could be a plugged fuel filter.

  4. #4
    Senior Member
    Join Date
    Apr 2011
    Location
    Tennessee
    Posts
    211
    or it could be the icm check to see if you have spark. the icm controls the injectors and the spark and they love to fail

  5. #5
    Full Member CowboyCadilac's Avatar
    Join Date
    Jun 2011
    Location
    Minnesota
    Posts
    23
    I bought a fuel filter for it today. Don't have time yet to get it put in so will post after I get it put in tomorrow. Thanks for all the help. Forgot to ad that I did go out today after it sat all night and tried starting it and it started right up. Ran for about 30 secs and then just like I turned the key off and died and wouldn't start again.

  6. #6
    Senior Member
    Join Date
    Apr 2011
    Location
    Tennessee
    Posts
    211
    try unplugging the temp sensor and starting it. its located next to the top radiator hose on the manifold

  7. #7
    Full Member CowboyCadilac's Avatar
    Join Date
    Jun 2011
    Location
    Minnesota
    Posts
    23
    Got the new fuel filter in tonight. Started up after priming the pump a few times. Ran for about 30 secs and died again and wouldn't start back up. Waited about 5 min and it started again and did the same thing over. Now it won't start again. Tried umpluging the temp sensor and starting it and still didn't start. So is my next option to replace ICM?

  8. #8
    Senior Member
    Join Date
    Apr 2011
    Location
    Tennessee
    Posts
    211
    try testing the pressure at the tbi i think it should be between 12-16 psi if you get good pressure and it still doent put out from the injectors my next thought would be icm there pretty cheap

  9. #9
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,448
    Blog Entries
    2
    When it will not start pour some fuel in throttle body.... if still no crank check for spark at the plugs... then at coil.
    If not probably be icm or pickup coil. Check resistance on the icm and pickup.
    If you get 800 to 1200 ohms of resistance they are good.
    The pickup is a old school / type of crank sensor.

  10. #10
    Full Member CowboyCadilac's Avatar
    Join Date
    Jun 2011
    Location
    Minnesota
    Posts
    23
    Ok so I bought the ICM today and not sure how to put it in or where it goes. Can anyone give me a heads up on how to install it?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 6
    Last Post: 08-12-2012, 01:04 AM
  2. 94 Chevy silverado starting problem
    By fjsenn4949 in forum Chevy Truck Forum
    Replies: 34
    Last Post: 12-19-2010, 12:13 PM
  3. 94 Chevy Diesel starting problem?
    By LuvMyChevyTruck in forum Chevy Truck Forum
    Replies: 7
    Last Post: 12-14-2010, 08:54 PM
  4. 1988 chevy g-20 van starting problem
    By blackls6 in forum Chevy Truck Forum
    Replies: 3
    Last Post: 08-02-2008, 05:14 AM
  5. 99 Chevy starting problem
    By chevyz71 in forum Chevy Truck Forum
    Replies: 2
    Last Post: 01-24-2006, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •