Results 1 to 6 of 6

Thread: 1989 chevy truck won't start

  1. #1
    Junior Member
    Join Date
    Jul 2006
    Posts
    3

    1989 chevy truck won't start

    I have a 1989 chevy truck with a 350 TBI that won't start. It turns over fine and you hear the fuel pump hum, but it won't start. If you dump a small amount of gas in the TBI housing it will start and run fine. The minute you turn the ignition switch off and try to restart it it will not start. The truck has 150K miles on it and it has been well maintained. The problem started a few times here and there and now does it all the time. I have installed a fuel pump and strainer, I rebuilt the TBI and installed a new AIC. I have checked all the fuses and think it is something to do with the injector signal at start up, but I can not find anything on it in my crappy haynes repair manual. Any help would be great.

  2. #2
    Senior Member chevyguy's Avatar
    Join Date
    Sep 2005
    Location
    ALABAMA
    Posts
    4,087
    sounds like low fuel pressure to me. Have you checked the fuel pressure, Should be between 13-9 psi any lower and it fuel pump time
    Window tint its for window, Not for tail lights. Don't be that guy .

  3. #3
    Full Member 1995C3500's Avatar
    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    39
    a 1992 at work had the same problem last year, it came down to that it needed a new filter, and the lines had to have water pressured through them cause a ton of dirt was in the lines and clogging it and until the engine was started it wasnt pulling enough fuel to run, it would sputter and spit but not do more than fail to start till we sprayed starter fluid down the tbi

  4. #4
    Full Member
    Join Date
    May 2006
    Posts
    35
    are you getting fuel at the throttle body?

  5. #5
    Senior Member Hayden's Avatar
    Join Date
    May 2006
    Location
    Bay City,Michigan
    Posts
    387
    It's junk. wanna sell it? lol
    There Is No Replacement For Displacement

  6. #6
    Junior Member
    Join Date
    Jul 2006
    Posts
    3
    It was the ignition modual. I never could find it in my repair manual. I found it on here and just replaced the part. It runs great now, ready for another 150K miles.

Similar Threads

  1. Help a Student..Take a Truck Survey
    By ClassSurvey in forum General Truck Forum
    Replies: 3
    Last Post: 07-08-2011, 01:51 PM
  2. chevy truck drivetrain swap, questions....
    By beachbum29 in forum Chevy Truck Forum
    Replies: 3
    Last Post: 11-23-2005, 05:23 AM
  3. 1989 Chevy Truck (Arizona Reporter)
    By trucknews in forum Truck News (headlines)
    Replies: 0
    Last Post: 04-12-2005, 06:30 PM
  4. Please help... truck died now wont start
    By jarrod in forum Toyota Truck Forum
    Replies: 8
    Last Post: 01-31-2005, 09:49 PM
  5. Replies: 0
    Last Post: 10-29-2004, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •