Results 1 to 10 of 10

Thread: 99 S-10 odometer problem, it went blank!

  1. #1
    Full Member
    Join Date
    Jun 2007
    Posts
    20

    99 S-10 odometer problem, it went blank!

    Hi I'm not new to truck forum, I've just been gone for a while, I used to be 2000silverado. Anyways, I've got a 99 Chevy S10 for my commute to work, about a 35 mile drive one way, the truck has around 150,xxx miles on it. And recently the digital odometer would not show or would blink off while driving. If I pushed the reset button/stem a few times it would eventually show back up. And then it would stay on for a few miles and go out again. Then it got to the point where it would never show up when I started up the truck, if I pounded on the steering wheel close to the cluster it would sometimes show back up/ sometime not... Now it's just blank. It is still keeping track of how many miles I'm driving, just not lighting up. What's going on?? Anyone ever have this problem, do you know what I can do to fix it?? I like keep track of my miles for, oh I don't know, thinks like when the next oil change is due, and what kind of fuel mileage I'm getting. Thanks for any suggestions, help. David-
    Dumb people make us look smart...

  2. #2
    Senior Member mrjohnwayne's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    4,054
    Not sure bud but welcome back.
    John Wayne

    2000 F-350 7.3L Powerstroke 4x4

  3. #3
    Full Member
    Join Date
    Jun 2007
    Posts
    20
    Anybody have any idea??!?!? Thank you for any info.
    Dumb people make us look smart...

  4. #4
    Junior Member
    Join Date
    Oct 2006
    Posts
    5
    Quote Originally Posted by dispatch View Post
    Hi I'm not new to truck forum, I've just been gone for a while, I used to be 2000silverado. Anyways, I've got a 99 Chevy S10 for my commute to work, about a 35 mile drive one way, the truck has around 150,xxx miles on it. And recently the digital odometer would not show or would blink off while driving. If I pushed the reset button/stem a few times it would eventually show back up. And then it would stay on for a few miles and go out again. Then it got to the point where it would never show up when I started up the truck, if I pounded on the steering wheel close to the cluster it would sometimes show back up/ sometime not... Now it's just blank. It is still keeping track of how many miles I'm driving, just not lighting up. What's going on?? Anyone ever have this problem, do you know what I can do to fix it?? I like keep track of my miles for, oh I don't know, thinks like when the next oil change is due, and what kind of fuel mileage I'm getting. Thanks for any suggestions, help. David-

    The same thing is now happening to my 99 gmc sierra 1500, i came here hoping to find help, i really don't want to have to buy a new cluster

  5. #5
    Senior Member greasemonkey's Avatar
    Join Date
    Jun 2007
    Location
    Central Pennsylvania
    Posts
    624
    This was a common problem with GM trucks. The only thing that can be done is disassemble the cluster and clean the inside with computer keyboard cleaner. If this doesnt help, the cluster is bad and a replacement will be required.

    Cummins 12 valve Turbo Diesel.

  6. #6
    Full Member
    Join Date
    Jun 2007
    Posts
    20
    Thanks for the suggestions, I was hoping it'd just be a loose wire but oh well....
    BTW nice user name there firedispatch1!
    Dumb people make us look smart...

  7. #7
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,170
    i think i would like the idea of a truck that could be driven without the hinderance of mileage later down the road. might be the bad coming out in me. tell the college kid with daddys wallet it has less miles than what you believe it to have.

  8. #8
    Junior Member
    Join Date
    Oct 2006
    Posts
    5
    Does anyone know If i replace the cluster will the milage be correct??
    Not a huge concern but just wondering

  9. #9
    Full Member
    Join Date
    Jun 2007
    Posts
    20
    I was thinking that would be kinda nice for later on when I sell it, not being able to see the truck has close to 200,000 miles might make it sell for more!! Ah, but the unknown always scares buyers away......
    Dumb people make us look smart...

  10. #10
    Full Member
    Join Date
    Jun 2007
    Posts
    20
    So now my odometer comes on when I go over a bump, pound the steering, etc. It usually stays on after that till I shut the truck off again. I think I'll just settle with it working 50% of the time then messing around with it.
    Dumb people make us look smart...

Similar Threads

  1. Abs Problem???
    By MARK326 in forum GMC Truck Forum
    Replies: 2
    Last Post: 03-27-2010, 03:37 PM
  2. front brake problem 03 Ford f250
    By hdkidd in forum Ford Truck Forum
    Replies: 4
    Last Post: 10-21-2009, 07:59 PM
  3. Transmission Problem
    By z71chevy1996 in forum Chevy Truck Forum
    Replies: 0
    Last Post: 12-23-2006, 04:05 PM
  4. '99 F250 SD with strange problem
    By ColoQuarterH in forum Ford Truck Forum
    Replies: 4
    Last Post: 08-20-2006, 09:37 AM
  5. 1997 chevy tahoe gage light problem
    By bajaboy in forum Chevy Truck Forum
    Replies: 5
    Last Post: 03-23-2006, 08:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •