Results 1 to 7 of 7

Thread: F250 speedo not working

  1. #1
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93

    F250 speedo not working

    We have a 2000 F250 gas engine, automatic, at work and the speedo quit. We changed sensor on transmission and still not working. Is there anything between the sensor and dash that could be causing this?

  2. #2
    Senior Member eponator's Avatar
    Join Date
    Nov 2008
    Location
    SO Cal
    Posts
    772
    Not sure which censor you swapped on the transmission but you might want to take a look at the VSS sensor on the top of the rear pumpkin. When they go, and they often go, they usually mess with the speedo. Just get down there with a wrench (10mm I believe) and pull the single bolt and check the sensor. Clean it off and put it back in then test to see if the speedo works. Or a replacement sensor and napa is around $25.

    Could be a cut in the line between the sensor and the dash or even a dead gauge. Don't know too much how to test for this, hopefully someone else with the knowledge can help you out here; but the VSS is always a good place to start.

    Any warning lights?
    '99 F350 5.4L crewcab Longbed

  3. #3
    Senior Member 72'CaminoKid's Avatar
    Join Date
    Jun 2005
    Posts
    2,757
    from what i've heard there is a problem with these speedo's and you have to send the whole unit somewhere to have it worked on, and its quite pricey. not positive though. i know my boss had this issue on his 03, he just decided to pass less people than are passing him instead of knowing his exact speed
    99 suburban xlt
    96 silverado
    91 wrangler (my baby )
    08 Honday shadow 750 (my mistress)

  4. #4
    Senior Member
    crabtruck's Avatar
    Join Date
    Jul 2007
    Posts
    5,566
    Quote Originally Posted by Robert78.5 View Post
    ... Is there anything between the sensor and dash that could be causing this?
    Gone are the days of the "home run" cable, non-stop to dash.
    About a half dozen things are in the mix.
    To isolate: if ABS works and cruise control works (at your best guess above 45mph)
    then you are most likely looking at IP cluster. If so, do the basic checks
    that connectors are tight. If speedo is only thing bad then probably it.
    Nothing came up when you checked codes ?
    No problems with shift points while driving ?

  5. #5
    Senior Member mrjohnwayne's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    4,044
    Quote Originally Posted by 72'CaminoKid View Post
    from what i've heard there is a problem with these speedo's and you have to send the whole unit somewhere to have it worked on, and its quite pricey. not positive though. i know my boss had this issue on his 03, he just decided to pass less people than are passing him instead of knowing his exact speed
    02+ are different than 99-01. 02 are electronic but have to be programed/calibrated via computer in house at ford etc..

    99-01 are still electronic but simple plug and play.
    John Wayne

    2000 F-350 7.3L Powerstroke 4x4

  6. #6
    Senior Member autoshopazn's Avatar
    Join Date
    Jul 2009
    Location
    San Diego, CA
    Posts
    178
    **** with it. forget about that speedo and put a autometer in. it deserves it.
    1990 Chevy C2500 350 5.7 V8; 55 Watt 10,000K HI/LO HID Lights; K&N Air Filter; Dual Optima Red Batteries; Pioneer Head Unit w/ 10" sub; Prodigy Brake Controller; Hankook Tires; Electric Fans

  7. #7
    Junior Member
    Join Date
    Sep 2009
    Posts
    3
    I have a MANUAL trans & the speedo soesn't work. Cable & plastic gear are new, speedo works when run by drill. I'm told it might be an expensive fix to take the trans apart.
    Any solutions?
    Are there any electric-type sensors like the above I could jury rig?
    Thanks

Similar Threads

  1. Speedo
    By brad4eva in forum Chevy Truck Forum
    Replies: 7
    Last Post: 11-27-2008, 10:19 PM
  2. speedo not working.
    By st6844 in forum Chevy Truck Forum
    Replies: 6
    Last Post: 09-24-2008, 11:05 PM
  3. Speedo off
    By phil111260 in forum Chevy Truck Forum
    Replies: 1
    Last Post: 05-22-2008, 01:01 PM
  4. My speedo. is off
    By sport in forum Chevy Truck Forum
    Replies: 26
    Last Post: 09-04-2007, 08:26 AM
  5. 2000 F250 Superduty speedo abs problems
    By bobm1965 in forum Ford Truck Forum
    Replies: 1
    Last Post: 02-25-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •