Results 1 to 10 of 10

Thread: F250 speedo not working

  1. #1
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93

    F250 speedo not working

    We changed the sender unit on trans, now we changed the instrument cluster with a Ford rebuilt, still no speedometer. Where to look next? year 2000 automatic 2 wd gas,

  2. #2
    Senior Member mrjohnwayne's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    4,044
    vss on these trucks is located on the rearend. also doubles as the abs sensor.
    John Wayne

    2000 F-350 7.3L Powerstroke 4x4

  3. #3
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93
    What does the sensor on transmission do than?

  4. #4
    Senior Member
    Join Date
    Nov 2009
    Location
    winchester, va
    Posts
    4,173
    it sends a signal to the speedometer telling it how fast you are going.

  5. #5
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93
    Thats what i figured but why does speedo not work?

  6. #6
    Senior Member mrjohnwayne's Avatar
    Join Date
    Apr 2005
    Location
    Texas
    Posts
    4,044
    the sensor on the tranny is also used as a speed measuring device... but the one that controls the speedo is on the pumpkin on the rearend. and I might have told you wrong. there might be 2 sensors on the rear end. depending if your truck is 2w abs or 4w abs.

    pretty sure you change the vss on the rearend and you'll get the speedo back.
    John Wayne

    2000 F-350 7.3L Powerstroke 4x4

  7. #7
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93
    ok will try

  8. #8
    Senior Member eponator's Avatar
    Join Date
    Nov 2008
    Location
    SO Cal
    Posts
    772
    JW beat me to it, check your VSS on top of the rear diff facing the front of the truck. If you find allot of metal flakes or dirt / grime built up on the end of it then clean it up, stick it back in and go for a drive. Sometimes its just dirty and cleaning it will get you back on the road quickly.

    If this doesn't work then I'd replace it. Cheap part, simple fix, its pretty self explanatory.

    You mind me askin how much that recalibrated speedo set ya back?? OH and are you tripping any ABS lights?? Any codes being thrown?
    '99 F350 5.4L crewcab Longbed

  9. #9
    Senior Member
    Join Date
    Sep 2006
    Location
    Manitoba
    Posts
    93
    I changed it now it works. should have tried that before changing cluster,
    Last edited by Robert78.5; 12-09-2009 at 04:06 PM.

  10. #10
    Senior Member eponator's Avatar
    Join Date
    Nov 2008
    Location
    SO Cal
    Posts
    772
    Glad we could help you get it working right again! Now, got any pics of that truck??

    '99 F350 5.4L crewcab Longbed

Similar Threads

  1. F250 speedo not working
    By Robert78.5 in forum Ford Truck Forum
    Replies: 6
    Last Post: 09-23-2009, 11:17 AM
  2. speedo not working.
    By st6844 in forum Chevy Truck Forum
    Replies: 6
    Last Post: 09-24-2008, 11:05 PM
  3. Speedo off
    By phil111260 in forum Chevy Truck Forum
    Replies: 1
    Last Post: 05-22-2008, 01:01 PM
  4. My speedo. is off
    By sport in forum Chevy Truck Forum
    Replies: 26
    Last Post: 09-04-2007, 08:26 AM
  5. 2000 F250 Superduty speedo abs problems
    By bobm1965 in forum Ford Truck Forum
    Replies: 1
    Last Post: 02-25-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •