Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Like Tree1Likes

Thread: 1975 F250 starting problems

  1. #1
    Newbie
    Join Date
    Aug 2012
    Posts
    5

    Question 1975 F250 starting problems

    Have a 75 F250 w/360 tried to start it and it would turn over but die, rebuilt the carb with same results. everytime the starter is engaged the engine will fire, when the key is let go it dies. Im figuring electrical possibly the coil or maybe the ignition module, it has electronic ignition with the module. theres not much to the motor being a 75. I know if the items are broke replacement will be required, but how to tell which one.

  2. #2
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,007
    Blog Entries
    2
    Sounds like the ignition .switch to me . See if there is power at ignition fuse when you let the key off.

    Gitter done have fun. Running on empty...running blind...running behind.....

  3. #3
    Newbie
    Join Date
    Aug 2012
    Posts
    5
    would that be the switch itself on the dash or the module

  4. #4
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,007
    Blog Entries
    2
    The switch on the dash turn it to on see if there is power on both side of the ignition fuse .
    Welcome to the site .

    Gitter done have fun. Running on empty...running blind...running behind.....

  5. #5
    Newbie
    Join Date
    Aug 2012
    Posts
    5
    I havent had a chance to check the fuses but I know that if I turn the key on all the dash lights come on, does that mean there is power going through the switch?

  6. #6
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,007
    Blog Entries
    2
    So your saying as long as starter is engaged turning the engine it runs? Try this check for power at the coil when key is on.
    Prime the engine see if it runs good for a few seconds when key is let off.

    Gitter done have fun. Running on empty...running blind...running behind.....

  7. #7
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,007
    Blog Entries
    2
    If it was coil or module you would not get spark at the plugs . Would not run at all . I,am thinking ignition switch problem .
    But here is a link how to check the ignition Part 1 -Ford Ignition Module Test. Fender Mounted Module (ICM).

    Gitter done have fun. Running on empty...running blind...running behind.....

  8. #8
    Senior Member elgemcdlf's Avatar
    Join Date
    Nov 2011
    Posts
    95
    Sounds like it might be a bad ballast resister. When cranking the resistor is bypassed providing 12V to the coil. When in run the resistor drops the voltage to something like 9.8V. I would run a wire from the + of the battery to the + of the coil & try to start. If it starts & stays running you are on the right track. To kill the engine you will need to disconnect this jumper wire. Do not run it this way as it will burn out your coil but you can do it for testing purposes.
    chevychase likes this.

  9. #9
    Newbie
    Join Date
    Aug 2012
    Posts
    5
    bought a new module and installed it, would not even fire even when starter engaged. put on the old one and when starter engaged fired until I released the key. bad module maybe, something else maybe. am going to use the jumper from the batt to the coil tomorrow, what size wire would be to small?

  10. #10
    Newbie
    Join Date
    Aug 2012
    Posts
    5
    will run when starter engaged but dies when key is let go, if you prime it it just revs higher then dies.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 32
    Last Post: 11-06-2012, 04:14 PM
  2. Starting problems
    By coyconner1983 in forum Chevy Truck Forum
    Replies: 16
    Last Post: 03-12-2009, 07:36 PM
  3. Starting problems with my 1999 Ford F250 Power stroke diesel
    By alohabird in forum Ford Truck Forum
    Replies: 5
    Last Post: 07-10-2008, 06:19 PM
  4. Strange starting problem 1999 F250 7.3L
    By Kawboy in forum Ford Truck Forum
    Replies: 14
    Last Post: 07-28-2007, 06:01 PM
  5. F250 cam sensor problems
    By sg883 in forum Introductions
    Replies: 1
    Last Post: 05-19-2006, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •