Results 1 to 10 of 10

Thread: P0894 - Transmission Component Slipping

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Posts
    5

    P0894 - Transmission Component Slipping

    On Friday, I bought a used 2005 GMC Sierra 2500 HD with the 6.0L engine. Before buying, I took it to a local garage, and had it inspected. Although the vehicle had high mileage (almost 99K) the mechanic told me it was in great shape, and said he couldn't see anything wrong with it. He said that the transmission fluid looked a little dirty (as if it hadn't been changed in a while) but didn't notice any metal shavings or unusual discolorations or smells.

    I bought the truck, had the garage change oil, transmission fluid and brake fluid, drove it off the lot, and filled it up with gas. Immediately after filling, the check engine light came on, but I didn't notice anything wrong, so I kept driving. I drove about 60 freeway miles, and noticed a slightly rough shift pattern after pulling off the freeway at my destination.

    When I arrived, I shut the engine off, visited for a while, and everything seemed fine. Drove about another 50 freeway miles and again noticed rough shift pattern after getting off the freeway. We plugged in our OBD2 reader, and came up with error P0894 - Transmission Component Slipping. We cleared the error code, but noticed it pop back on after about 20 miles of freeway driving.

    I checked with the garage that originally inspected and serviced the truck and was told they had seen nothing that would indicate any sort of major problem with the transmission. I took the truck to our local Chevrolet dealer (no GMC dealer close by) and they told me that my transmission is in serious trouble and needs to be completely replaced to the tune of $3,322.22.

    Other than the slightly rough shifting after getting off the freeways (which goes away just as soon as I shut the engine on and restart) I haven't noticed any problems with the transmission. When it's completely cold and running in city traffic, it shifts nice and smooth.

    The dealer said they were able to diagnose this problem without actually opening up the transmission, by just plugging test equipment into the vehicle.

    I'm feeling rather suspicious that the dealer may be trying to sell me a new transmission when one is not necessary, so I will take the truck to a transmission shop for a second opinion. Does anyone have any ideas on what might be causing this problem? Do I really need a new transmission, or is the dealer just trying to take me for an expensive ride?

  2. #2
    Senior Member
    Join Date
    Dec 2007
    Posts
    2,206
    truck that new uses and input and output speed sensor and is smart enough to know calculated by what gear it is in what the speed changes should be, but if you are feeling problems there probly is something going on, did they use the correct fluid when they changed it, i think those newer trucks use special fluid like dextron four or five er something, that could cause a problem maybe,...

  3. #3
    Senior Member NCroadracer's Avatar
    Join Date
    Apr 2007
    Posts
    307
    Sounds like the problem was most likely due to the shade tree garage using the wrong fluid or crappy bulk shi_t and some harsh flush chemicals.

    Have the dealer flush it with Dexron5 and ask them if they can reset the TAPS when they clear the code. Try that before you fork out the loot for a SRTA (remand trans)

  4. #4
    Junior Member
    Join Date
    Feb 2008
    Posts
    5

    Garage Used Multi Vehicle ATF

    I checked with the garage, and they used a multi vehicle ATF. Several Google searches seem to indicate that this fluid is compatible with the DEXRON III.

    Did the garage use the wrong stuff?

    Based on my talks with the shop owner, he seems careful and knowledgeable. Frankly, the dealer feels a little shady to me, because they are recommending a complete transmission replacement, even though they haven't actually opened up the tranny to have a look inside.

    They are claiming, just from the computer diagnostic codes, that I have a fatal problem, which just seems a little suspicious to me.

  5. #5
    Senior Member
    Join Date
    Dec 2007
    Posts
    2,206
    best thing to do is read your manual to see what is supposed to be in your tranny, to rule out bad oil idea,...

  6. #6
    Senior Member
    Join Date
    Jan 2008
    Posts
    105
    do you feel the torque converter lock up?
    try driving out of overdrive and see if it'll flag the codes.

    i burned overdrive out of my 4l60e twice....

    rebuilt it yourself man, $700 at the most in parts.....that's including the book.... except you have the 4l80e i think.

    GM likes to:
    tell you the worse scenario, they want to put in a new trans
    tell you the most expensive part they can sell.
    tell you need to buy the complete whatever for a $400 to buy a $3 peice of wiring harness.

    GM likes money.

    and as far as the hot runs bad cold runs good. when i rebuilt my trans the first time, it was awesome cold, and soon as it's hot, flags a service light, and goes into limp mode. only 2nd, nothing else. shut it off, start it up cold, aewsome, all 4 gears with torq converter, gets hot, service light and only 2nd.

    had to take it to the dealer and flashed the computer for $200. yes, $200 to hook up a cable and send some electricity to it. 10 minutes. wtf right?

    anyways, like i said, burned the overdrive out again, and rebuilt it, again, but didn't have the computer problem. probably not what your experiencing, but, may as well let everyone know, its how we learn.
    1996 Z71 white shortbox tinted
    350 30 over
    cats and X pipe
    Alumhds ported 210 cc runners 62 cc chambers 2" int 1.550" ex
    crane lift; 580/580 duration; 216/222
    4L60E w/shiftkit

  7. #7
    Senior Member NCroadracer's Avatar
    Join Date
    Apr 2007
    Posts
    307


    GM likes to:
    tell you the worse scenario, they want to put in a new trans
    tell you the most expensive part they can sell.
    tell you need to buy the complete whatever for a $400 to buy a $3 peice of wiring harness.

    GM likes money.

    GM ( General Motors as a corporation) doesn't repair vehicles, they manufacture them and supply them to dealerships who sell them.
    Each dealership is independently owned and as a part of the franchise stipulation they must also have a service dept. with GM certified technicians who also must meet certain training standards set forth by GM..
    Each dealership will have good techs and half arsed techs.
    Some don't have transmission specialists and some do.
    You may have had a bad experience with your local dealership, but that doesn't warrant the blanket statements you seem to like to make.

    I'm a technician myself, with a few years under my belt (17 years Master certified)... If i were the kind of person you want people to think all dealer techs are.... would i be here offering FREE advice to the forum members when they ask?... Probably not!

  8. #8
    Junior Member
    Join Date
    Feb 2008
    Posts
    5
    I took the truck in to a transmission shop, and they did a tear-down and determined that the 4th gear is burned out and the torque converter is bad.

    The shop gave me four options:
    • Replace the bad gear and torque converter - $1,500
    • Do an in-house rebuild, 1 year/12,000 mile warranty- $2,200
    • Replace transmission, 1 year/12,000 mile warranty - $2,700
    • Replace transmission, 3 year/36,000 mile warranty - $3,000
    Although someone suggested that I rebuild this myself, I have to be honest and say that I don't have the time, tools or mechanical ability to do this myself.

    The in-house rebuild has a 1 year/12,000 mile warranty, but it has the disadvantage of only 6 months of that warranty will be honored nationally.

    I've been told it's better to keep the existing transmission whenever possible, but certainly the warranty is better with other options. Does anyone have any suggestions?

    Thanks!

  9. #9
    Senior Member NCroadracer's Avatar
    Join Date
    Apr 2007
    Posts
    307
    For close to the same money you could have your GM dealer replace it with a SRTA and get a 3yr 100KMI parts/labor war, which would be honored at any GM dealership nationally.

  10. #10
    Junior Member
    Join Date
    Feb 2008
    Posts
    5
    Just a quick follow-up on this... I ended up going with the less-expensive in-house rebuild. Although having a 3 year warranty sounded nice, I wasn't really prepared to spend an extra $1,000 on the truck right now.

Similar Threads

  1. 02 Silverado Trany Slipping
    By Kevin Hod in forum Chevy Truck Forum
    Replies: 14
    Last Post: 07-29-2008, 11:02 AM
  2. Slipping
    By colbyj86 in forum GMC Truck Forum
    Replies: 3
    Last Post: 07-28-2007, 06:18 PM
  3. Auto trans slipping in reverse?
    By milemaker13 in forum GMC Truck Forum
    Replies: 7
    Last Post: 03-31-2007, 05:25 AM
  4. e40d was slipping
    By flyer181 in forum Ford Truck Forum
    Replies: 3
    Last Post: 01-13-2007, 09:19 PM
  5. Transmission was slipping. LUCAS ADDITIVE
    By gmctrucks in forum Off-Topic
    Replies: 6
    Last Post: 12-15-2006, 09:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •