Results 1 to 5 of 5

Thread: Urgent!! truck not starting!!!

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Posts
    8

    Exclamation Urgent!! truck not starting!!!

    two days ago when i went to leave the hardware store my truck would not start. It would roll over strong as it always does but it seemed like it wasn't getting any spark/fuel to get it running. I opened the hood and jiggled some wiring around and tried once more, and like the flick of a switch it just started without hesitation. It definitly seemed like there was a loose connection somewhere but i drove home hoping it wouldn't occur again....
    Well this morning it happened again, but this time it just wont fire, no matter how much i jiggle the wires . I took out a spark plug and i tested it for spark and it appears that it isnt getting any spark while the engine is rolling over. im very scared of electrical problems and am kinda new to owning a vehicle so i was wondering if there was a common problem with the distributor or some wiring that comes loose sometimes that's not easy to see? The engine runs smooth and never ran rough after it started at the hardware store, which i think means that the coil/spark plugs are still good.
    Last edited by blue_1500; 10-16-2009 at 04:40 PM.

  2. #2
    Senior Member gmctrucks's Avatar
    Join Date
    Nov 2006
    Location
    Houston,Texas
    Posts
    6,305
    What wires did you move around and what year truck and engine is this truck? We need more input now don't start replacing parts thinking that's it hang out and wait for answers.
    GMC

  3. #3
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,159
    got to go with GMC on this one. which wires did you move the first time to get it to crank?? had a problem similiar to this once. turned out the coil wire broke inside the insulation and was not visually hurt. once i tried to remove the wire, it fell to pieces.

  4. #4
    Junior Member
    Join Date
    Aug 2009
    Posts
    8
    I played around with the volt meter last night and found that it was acually the pink wire from my ignition switch to the coil that had come loose. I didnt reach back and jiggle those wires the first time but i guess it was just a bad connection. thanks for the replies, I feel a little more confident in my diagnosis now

  5. #5
    Senior Member gmctrucks's Avatar
    Join Date
    Nov 2006
    Location
    Houston,Texas
    Posts
    6,305
    I'm glad you fixed it and thanks for letting us know what it was we all learned something today.

Similar Threads

  1. Truck not Starting
    By blue_1500 in forum GMC Truck Forum
    Replies: 20
    Last Post: 10-16-2009, 07:31 PM
  2. Picked up truck, starting question
    By partsman in forum GMC Truck Forum
    Replies: 17
    Last Post: 02-26-2009, 11:27 AM
  3. Urgent
    By Dearman@MS in forum Dodge Truck Forum
    Replies: 7
    Last Post: 06-01-2008, 08:54 AM
  4. Help truck is not starting
    By colbyj86 in forum Chevy Truck Forum
    Replies: 6
    Last Post: 12-03-2007, 07:23 AM
  5. transmission ????????????????? urgent
    By mikerike in forum Chevy Truck Forum
    Replies: 2
    Last Post: 11-14-2005, 01:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •