Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: 1994 GMC C1500 battery drain

  1. #1
    Full Member
    Join Date
    Dec 2012
    Posts
    22

    1994 GMC C1500 battery drain

    Ok guys for years I've had a battery drain on my 1994 GMC C1500. If you start it every 3-5 days it's fine but left for a week or two and the battery will be dead. I've looked around and done some testing but really never found anything that I would consider enough to be the problem. I've done the fuse puller idea and looked for sparks but nothing really stood out. Can someone lead me in the right direction to start?

    I will give you some info. I bought this truck brand new so I know every part that has ever been replaced. For the most part it is completely stock. I did have an amplifier added back when it was new. I've also disconnected this amplifier first to see if this was the problem and the battery still drains after a week so I'm going with this isn't what is causing the battery drain. I have a volt meter but really not knowledgeable on exactly how to use it.


    thanks,

    JG

  2. #2
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,556
    Blog Entries
    2

    Gitter done have fun. Running on empty...running blind...running behind.....
    IF I CAN GET YOU TO SMILE BEFORE I LEAVE.

  3. #3
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    That video link that Chevychase posted should get you fixed here. It could be a number of things and can come out of nowhere. Using the approach above will certainly help you find the problem. Just remember to keep your mind open to the cause here and certainly consider that the battery might be the cause. If it were me, I would first test the battery with your multimeter by simply testing the voltage at the terminals. If the battery is 100% charged....you should see a solid 12.6 volts on the multimeter.

    Based on what I can think of here....you either have a parasitic drain (like an underhood light that won't shut off when you close the hood)....or you have a battery that is unable to be charged fully. All I am saying is that based on your description of what it going on....don't be so quick to say it is certainly a parasitic drain.

  4. #4
    Moderator
    Join Date
    Jul 2011
    Location
    Central Oklahoma
    Posts
    4,333
    I would have the battery tested, if its still good then look at the power drain. Do you have a power cap hooked up with the amp? Might disconnect that, if its bad it could draw current trying to stay at full power.
    1994 white ext cab chevy silverado 5.7 rolling 230k miles
    stock with air filter lid flipped,
    open flowing exhaust to a 40 series flowmaster dumped.
    God Bless America, Support our Troops!

  5. #5
    Full Member
    Join Date
    Dec 2012
    Posts
    22
    I'm going to totally disconnect the amp when doing my test.

  6. #6
    Full Member
    Join Date
    Dec 2012
    Posts
    22
    For some reason it won't let me upload any pics? Can anyone help? When I click on Manage attachments it pops up but then turns all grey?

  7. #7
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,556
    Blog Entries
    2
    Left pm to administrator on this . I can not even post any . Maybe senior mod. mudseeker he is the pro. can look into it.
    Others for awhile have been having trouble.

    Gitter done have fun. Running on empty...running blind...running behind.....
    IF I CAN GET YOU TO SMILE BEFORE I LEAVE.

  8. #8
    Moderator
    Join Date
    Jul 2011
    Location
    Central Oklahoma
    Posts
    4,333
    Can you upload to a place like photo bucket then post the links here.
    1994 white ext cab chevy silverado 5.7 rolling 230k miles
    stock with air filter lid flipped,
    open flowing exhaust to a 40 series flowmaster dumped.
    God Bless America, Support our Troops!

  9. #9
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,556
    Blog Entries
    2
    no i tried all

    Gitter done have fun. Running on empty...running blind...running behind.....
    IF I CAN GET YOU TO SMILE BEFORE I LEAVE.

  10. #10
    Newbie
    Join Date
    Nov 2012
    Posts
    4

    do you have courtesy mirrors on the visors?

    Quote Originally Posted by chevychase View Post
    no i tried all
    women use theirs alot more than the guys do. mine was sagging just enough on her side to cause the light to be on when it appeared to be closed. worth a check.

Page 1 of 3 123 LastLast

Similar Threads

  1. 1994 chevy c1500 will not start. Any suggestions?
    By islandwoman28 in forum Chevy Truck Forum
    Replies: 11
    Last Post: 07-28-2009, 03:42 AM
  2. Is this a bad Power Brake Booster? 1994 2WD C1500
    By jvfante in forum Chevy Truck Forum
    Replies: 24
    Last Post: 02-20-2009, 04:28 PM
  3. 07 Battery Drain
    By saltr in forum GMC Truck Forum
    Replies: 6
    Last Post: 07-17-2008, 03:50 PM
  4. 1994 GMC Sierra 4X4, EGR prob., battery drains
    By trunkmonkey in forum Chevy Truck Forum
    Replies: 5
    Last Post: 04-01-2008, 05:15 PM
  5. 1994 Chevy C1500 5.7 TBI, won't start, I need help!?!
    By moonpie41 in forum Chevy Truck Forum
    Replies: 15
    Last Post: 02-03-2008, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •