Results 1 to 7 of 7

Thread: Rough running 1996 Vortec 454

  1. #1
    Senior Member
    Join Date
    Jul 2008
    Location
    Poco BC
    Posts
    282

    Question Rough running 1996 Vortec 454

    So last year I did the wires on the truck as one pulled apart, ended up having to buy whole new set, anyway did spark plugs recently and one wire broke again, so had to buy a new set, but as the others are not that old I just replaced the broken one.
    Fired it up before I reconnected the air cleaner, and the maff I think they call it was not hooked up so got a code right away, so put it all back together and cleared code, did fuel filter also as I had not done it when I changed my fuel pump a year or so ago.
    Anyway now in the last little while truck will stumble while sitting or driving and nothing seems to be out of sorts, no codes.
    I was told because I buy my gas at Costco that could be it, but I put in fuel injector cleaner and that should keep it clean.
    One thing I thought was maybe that fuel press regulator inside the upper manifold, but a mechanic told me I would smell gas if that was not good.
    So any ideas on where to start looking for problems?
    Cap and rotor were done at least two years ago I recall.

  2. #2
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,295
    Blog Entries
    2
    Without a code could be fuel ..or spark related . Could clean the maf will cause your symptoms if dirty..and air plenum from air filter to throttle body is not sealed up air tight. The maf reads air flow any unmeterd air will cause problems ..get maf cleaner at auto parts..take maf off spray good..let dry..do not touch the filaments on the maf. just spray good. You know now to disconnect the battery first?? This will be a good place to start without a code.
    Oh if it was the regulator you would get long start times..then no start. You have to replace whole spyder injector on your to replace regulator..cheaper.
    The reg. connected to the spyder no vacuum line ..gets vacuum from sealed system under the intake. Seems this will be your problem did not start till you messed with stuff.

    Gitter done have fun. Running on empty...running blind...running behind.....

  3. #3
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    No codes does make for a more difficult diagnosis. Don't worry about the whole "cheap gas" scenario. Unless you get fuel from a "Pure" station (usually found at your marinas)....they will all have a 10% ethanol content.

    I would put you on a fuel pressure gauge to test both at initial key on (not start) to determine pressure and then again while running. Emphasis on the running test since the first one usually will tell you if it isn't high enough to start the truck. You should have at least 50 psi while running.

    Most of your ignition related issues will throw a code....so I'm leaning towards fuel related (pressure).

    As far as the fuel additive.....what did you use? Not that it matters concerning your problem.....but if you are looking to negate the effects of ethanol and make for a better fuel....some are better than others mainly because of the purpose they are designed for. Something like Lucas fuel treatment is something I use a lot and certainly would be what would best overcome poor quality fuel.

  4. #4
    Senior Member
    Join Date
    Jul 2008
    Location
    Poco BC
    Posts
    282
    I was thinking, a couple years ago we had mice or rats or something getting under the hood of the wifes car and my truck, they did chew one wire to her injector, and the insulation under the hood, and the plastic caps on the top of the shocks towers, on her tempo and once I fixed it the car was fine, they left food under my truck hood but in all this time no evidence they chewed anything, but now I am wondering if they might have got at something, maybe it might be worth while taking the top manifold off and looking to see if they might have finally chewed something on mine?

  5. #5
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    16,295
    Blog Entries
    2
    Might of..varmints can cause havoc.. i would put some dcon out..Mr partsman.

    Gitter done have fun. Running on empty...running blind...running behind.....

  6. #6
    Senior Member
    Join Date
    Mar 2008
    Location
    Plymouth, MA
    Posts
    238
    If I recall you stated in the first post you "replaced one (1) spark plug wire". If correct, try a whole new set, cap and rotor before getting into this thang. Just a thought.

  7. #7
    Senior Member
    Join Date
    Jul 2008
    Location
    Poco BC
    Posts
    282
    Well the old wires were replaced last year, because one broke and had to buy a new set, but then I broke one and had to buy a whole set again, but just replaced the broken one due to time constraints, but this set I bought is OEM Delco, so maybe I should do the whole set, rotor and cap are at least three years old, but had one guy at work say he didn't think that would be it, but then we get a lot of rain here and it has been I am sure three years, so maybe time to go over it again.

Similar Threads

  1. 1996 vortec 305 missfire
    By Buroaktree in forum GMC Truck Forum
    Replies: 11
    Last Post: 06-02-2009, 12:52 PM
  2. 1996 vortec 305 to a 350
    By jessie_london in forum Chevy Truck Forum
    Replies: 6
    Last Post: 02-03-2009, 08:57 PM
  3. 1997 Nissan SE 4x4 rough running motor
    By bpmhal in forum Nissan Truck Forum
    Replies: 5
    Last Post: 02-19-2008, 06:39 PM
  4. rough running
    By Rodney Hanson in forum Chevy Truck Forum
    Replies: 5
    Last Post: 12-12-2006, 04:02 PM
  5. Rough Running
    By smokejumper0902 in forum GMC Truck Forum
    Replies: 3
    Last Post: 03-13-2006, 06:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •