Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: starting problems for a 1998 1500

  1. #1
    Junior Member
    Join Date
    Nov 2013
    Posts
    9

    starting problems for a 1998 1500

    I have a problem with my 1998 1500. It turns over really hard and draws a lot of power when it turns over. Also there is a hard thunking sound every other turn over. We tried boosting it to see if the battery was dead but there was still hard to turn over.

  2. #2
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    Sounds like your starter solenoid is about gone....or you have something shorting out. If I am understanding what you wrote correctly....I certainly think that you need a new starter. Did this come on all the sudden? Does it end up starting the truck?

    If you want, you certainly can get it tested first and confirm that it is drawing way too many amps.....and if you can't find a wiring issue or any other reason for it doing this.....the only thing left to point the finger at is the starter.

  3. #3
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    Be sure to at least check the main power cable going to the starter itself and make sure it is tight and corrosion free first. As far as the starter current draw test....that is where I would go next.

    Is the battery good? You can check the voltage with a multimeter and see if it is or not. I would also do a load test on the battery to confirm that it is good just to get it out of the equation. Get the simple stuff out of the way first like checking the connection at the starter and making sure it hasn't worked its way loose at all or that the power cable hasn't had corrosion leech inside of the outer shield. A mulitmeter would really be helpful here. Most of your part stores will do the testing of the starter and the battery for free. Hope this helps.

    Welcome to the forum.

  4. #4
    Junior Member
    Join Date
    Nov 2013
    Posts
    9
    It happened all of a sudden, it was parked for about two weeks and it wasn't driven much before that. I plugged the block heater in over night, disconnected the battery and charged it up. Then it fired up like normal. It seemed like it was fuel locked, can that happen in a fuel injected? I think what may have been drwing power was my fuel pump because after its running I can still hear the fuel pump buzzing so I might just neeed a new fuel pump. Thanks for your help.

  5. #5
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    I don't know what you mean by "fuel locked". I also am not sure what you mean by the fuel filter buzzing after you shut it off. Before you start throwing parts at the problem and potentially waste money on parts you don't need....I suggest you let us help you do a little diagnosing first. There is a chance it might be the fuel pump....but you certainly do not want to have to go through the hassle of replacing the in tank pump if you don't have to. Trust me....it's a job you want to only have to do if you know your pump is bad. You either have to drop the fuel tank of take off the bed of the truck just to access it.

    There certainly are a few things to test first that are easy to do and can potentially save you time and money. Since you mentioned the battery being possibly discharged....Do you have an electrical multimeter? If you don't....take the battery to a local auto parts store and have it load tested. Certainly don't want to go any further if you don't have a good battery. In the meantime....tell me about this fuel pump. When you turn the key to the "on" position....but not start....do you hear the fuel pump come on? What about this fuel pump running when the truck is off? Certainly you aren't saying that your fuel pump is running when you don't have the truck on....right? Try and describe that again so I know what you are saying.

  6. #6
    Junior Member
    Join Date
    Nov 2013
    Posts
    9
    By fuel locked I mean that the engine seemed flooded,or got overfuelle. By fuel filter buzzing I meant it stayed on when the truck was running. It turns on when the key is on until its primed like it is supposed to but it turns on again afyer the truck is started then it stays running until the truck is off. The fuel pump quits after the truck gets shut off but it shuts off about two seconds after the truck is shut off.

  7. #7
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    14,838
    Blog Entries
    2
    Check starter is not loose/thumping power drain??...fuel pump will run the whole time truck is running.
    Service engine light on?

    Gitter done have fun. Running on empty...running blind...running behind.....

  8. #8
    Senior Moderator chevychase's Avatar
    Join Date
    Oct 2010
    Location
    truck forum .org
    Posts
    14,838
    Blog Entries
    2
    Even if it was fuel locked as you say..will not have a power drain?

    Gitter done have fun. Running on empty...running blind...running behind.....

  9. #9
    Forum Moderator Boudin's Avatar
    Join Date
    Jul 2009
    Location
    Central Mississippi
    Posts
    4,458
    Your fuel pump is acting normal. It wouldn't be draining your battery at all. Flooding is not an issue that happens like it used to with carburetors. The only way confirm that you need a new fuel pump would be a pressure test. If it can't provide 58 psi primed and at least 50 psi running....then it's time for a new one. I really don't think your fuel pump has anything to do with your issue here.

    I would go back to what I originally said and confirm tightness of connections and that the main power cable isn't corroded internally. Get your battery tested.

    I doubt you do....but any CEL?

  10. #10
    Junior Member
    Join Date
    Nov 2013
    Posts
    9
    Service engine light is not on and the starter is tight.

Page 1 of 2 12 LastLast

Similar Threads

  1. starting problem - 2006 GMC Sierra 1500
    By edapeman in forum GMC Truck Forum
    Replies: 8
    Last Post: 01-18-2011, 12:54 PM
  2. 96 Chevy silverado 1500 starting problem
    By nspen in forum Chevy Truck Forum
    Replies: 4
    Last Post: 11-22-2010, 08:29 AM
  3. 1988 chevy 1500 4x4 starting problem
    By puzzled in forum Chevy Truck Forum
    Replies: 12
    Last Post: 02-04-2010, 11:37 AM
  4. 1998 1500 chevy starting problem-popping p1626 code?
    By craigchaselisa in forum Chevy Truck Forum
    Replies: 5
    Last Post: 03-21-2009, 12:04 PM
  5. 2007 1500 hemi starting problems
    By carlskl in forum Dodge Truck Forum
    Replies: 2
    Last Post: 06-02-2008, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •