Results 1 to 5 of 5

Thread: bad running engine

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    6

    bad running engine

    I am at a stump here. I thought I had bad gas in my 94 hardbody, 4 cyl, approx 200K miles. it is idling very rough. I changed the fuel filter and the fuel line to the filter, but didn't get any better. I added a bottle of HEAT and it ran better for about a day. I had this problem once when the injectors were clogged, so I sprayed car cleaner into the throttle body, but didn't do any good this time. I pulled a couple plugs and they look normal. there was some carbon buildup on the contacts inside the distributor cap so I replaced that and the rotor, but still no difference. I thought the cat converter was clogged, but after removal of that, it still didn't do any good. it runs just fine when I rev the motor and on the highway, but it's rough holding rpms below say, 2000. I sure hope it's not a cam problem, I don't have the money to dump into it right now!

  2. #2
    Senior Member
    leolkfrm's Avatar
    Join Date
    Mar 2008
    Location
    N.Y.
    Posts
    8,849
    did you check for a vac leak, or EGR if it has one.....sorry it is a basic general answer as i don't do foreign
    4 wheels move the body
    2 wheels move the soul
    B.W.A.I
    Snow is a lot like religion and a lot like sex....you never know when you are going to get it!....or how much you will get

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Posts
    6

    bad running engine

    I have checked for vaccum leaks and have found none. I am going to check the egr valve here in a few minutes. I don't know if I mentioned in my original post, but I can tell it is running very rich. would a vaccum leak or egr problem cause that?

  4. #4
    Junior Member
    Join Date
    Oct 2009
    Posts
    6

    Talking better running truck

    Thanks leo for the tip about the egr valve. I looked in my haynes manual on how to test it. I pushed up on the diaphram while it was running and when I let go, it ran as good as new. I guess there might be carbon buildup around it. would seafoam be the best thing to clean it out with? I read once to pour some into a cup and apply thru a vaccuum hose. if I do that, will it foul the plugs? if so, I can just buy new ones. I think I will wait and see if it does it again to decide whether or not to do it. I sure am glad I didn't spend too much money on it by throwing parts at it. thanks again for the tip, now I can go back to work knowing that I won't break down because of it.

  5. #5
    Platinum Member
    bradrhale's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    11,158
    remove the EGR and clean it with BrakeKleen. it is a non oil based solvent/cleaner that will not affect operation or damage parts. clean it out real good and see if it works. if not, buy a new one.
    you can run the seafoam is you so choose to but doubt if it will help the EGR any. only thing it will clean through the vac hose is the valves though. you might lookin into putting some into the gas tank to help the injectors as well.

Similar Threads

  1. Engine Just Quit Running
    By Leroy in forum Dodge Truck Forum
    Replies: 4
    Last Post: 07-17-2009, 02:11 PM
  2. Engine running bad at normal temp!
    By Ernie R in forum Chevy Truck Forum
    Replies: 8
    Last Post: 03-30-2009, 02:08 PM
  3. Engine misfire detected engine code HELP
    By Airforce wrench in forum Chevy Truck Forum
    Replies: 2
    Last Post: 02-21-2008, 08:13 PM
  4. engine stops running
    By chief573 in forum Chevy Truck Forum
    Replies: 2
    Last Post: 07-30-2006, 04:59 PM
  5. Engine dying afte running a few mins. on 89 s-10
    By Polaris 500 in forum Chevy Truck Forum
    Replies: 7
    Last Post: 01-22-2006, 04:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •