02 chevy cold start rough idle

Discussion in 'Chevy Truck Forum' started by drozzus, Feb 21, 2012.

  1. drozzus

    drozzus New Member

    Joined:
    Feb 20, 2012
    Messages:
    3
    Likes Received:
    0
    i have a 2002 chevy silverado 4wd 5.3 v8 with 143,000 miles on cold start the rpms ramp up to 200 for about 30 secs and drop to around 500 and barely stays running. after warms up runs fine, a local mechanic changed 02 sensors all 4, plugs, wire, cleaned injectors and throttle body. i changed tps sensor and ran fuel injector cleaner thru tank. i have codes of too lean bank 1 and 2 random cylinder misfire, and idle air excessive. any help would be appreciated
     
  2. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,779
    Likes Received:
    6,760
    what is the reading on the scanner for the ecm temp sensor?
     
  3. drozzus

    drozzus New Member

    Joined:
    Feb 20, 2012
    Messages:
    3
    Likes Received:
    0
    I don't know will have to check
     
  4. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,147
    Likes Received:
    12,690
    Your getting to much un metered air in ..check for vacuum leaks at throttle body..air filter system...to throttle body
    Make sure it is all sealed tight...pcv valve... check all hoses...check the idle air control valve.
    Also clean the maf sensor.
     
  5. drozzus

    drozzus New Member

    Joined:
    Feb 20, 2012
    Messages:
    3
    Likes Received:
    0
    Ok will check it out
     

Share This Page