1987 Chevy C-10

Discussion in 'Chevy Truck Forum' started by Skeeter1984, Dec 22, 2011.

  1. Skeeter1984

    Skeeter1984 New Member

    Joined:
    Dec 22, 2011
    Messages:
    3
    Likes Received:
    0
    I have a 1987 C-10 with the TBI 4.3V6. It does start will run when I'm giving it gas but won't idle. In addition while running if I turn on the lights it will die out. What could cause this problem?
     
  2. MikeG

    MikeG Full Member

    Joined:
    Feb 26, 2011
    Messages:
    2,204
    Likes Received:
    1,273
    Sounds like a drain in the electrical system. Might want to look into getting a bigger (for lack of better words) alternator.
     
  3. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,693
    Likes Received:
    6,630
    put a charger on it and see if it stays running
     
  4. Skeeter1984

    Skeeter1984 New Member

    Joined:
    Dec 22, 2011
    Messages:
    3
    Likes Received:
    0
    Already have new battery and alternator. It even does this when on jumper cables. Any other suggestions?
     
  5. Case 7230

    Case 7230 Senior Member

    Joined:
    Dec 15, 2007
    Messages:
    1,645
    Likes Received:
    53
    Could be a bad/dirty idle air control valve (IAC) or bad throttle position sensor (TPS) or bad/leaking EGR valve. Maybe check for trouble codes as a first step (can do this with a paperclip).
     
  6. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,146
    Likes Received:
    12,679
    Does it start back up without boosting when it quits?
     
  7. Oldmech

    Oldmech Full Member

    Joined:
    Jan 12, 2010
    Messages:
    1,755
    Likes Received:
    210
    do what he said.. sounds like a vac leak bringing the rpm down too far to maintain the load on the alternator.. IAC/EGR cuod cause that.. bad or dead spot in your TPS.. might even be a temp sensor for the computer reading that its really cold even after its warmed up and flooding it.............
     
  8. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,693
    Likes Received:
    6,630
    when you changed the alternator...did you check all the driven parts to make sure they turn freely?
     

Share This Page