1994 k1500 5.7 - overheating

Discussion in 'Chevy Truck Forum' started by hvfd539, Mar 20, 2011.

  1. hvfd539

    hvfd539 Member

    Joined:
    Feb 16, 2011
    Messages:
    6
    Likes Received:
    0
    got a 94 k1500 5.7 350. it keeps runnin hot. in tryin to narrow it down
    i've replaced the radiator, fan, water pump, thermostat, and coolant temp sensor.
    i know the thermostat is workin cuz i put it in a pot of water on the stove.
    both radiator hoses are hot so its circulating water. im at a dead end
     
    Last edited by a moderator: Apr 23, 2011
  2. dannyboy950

    dannyboy950 Full Member

    Joined:
    Feb 20, 2011
    Messages:
    17
    Likes Received:
    0
    Check your radiator and condensor for obstruction to air flow. Check your fan is working properly. Check that your transmission is not running too hot.
    Possible head or gasket issues as well.
     
  3. zombie1969

    zombie1969 Senior Member

    Joined:
    Jun 30, 2010
    Messages:
    1,016
    Likes Received:
    16
    First off how sure are you its actualy running hot.Try installing a mecanical guage to verify the temp.And how hot is it getting?If it is running hot could be whats stated above with the head gasket or air flow.A head gasket will cause excessive pressure in the system and blow the coolant out the surge tank causing a low cooland situation.Is the coolant low or loosing coolant?You said you replaced the fan.Did you mean the clutch for the fan also?A bad clutch will cause a engine to run hot.Also how does the power feel?A partialy cloged cat can cause it to run hot also.
     
  4. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,147
    Likes Received:
    12,690
    Timing maybe advanced to far... how hot does it get.. does it get hotter under load?
    Does it ping / detonate?
     
  5. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,781
    Likes Received:
    6,766
    you replaced the fan or the clutch for the fan? make sure it is the heavy duty one....if it is getting hot you should hear it roaring
     
  6. hvfd539

    hvfd539 Member

    Joined:
    Feb 16, 2011
    Messages:
    6
    Likes Received:
    0
    ive replaced the clutch in the fan. it runs hot as it eill go. ill cut it off before it reaches 260. and it runs the same idlin or under a load. the cats shouldn be stopped up. power feels good and the exaust is only bout a year old. headders w high flow cats true duals. the thermostat will open and the temp will drop. but then the temp will just rise till i chave to cut off the truck
     
  7. zombie1969

    zombie1969 Senior Member

    Joined:
    Jun 30, 2010
    Messages:
    1,016
    Likes Received:
    16
    Seems you covered just about everything for the cooliing system..Id start to question if the pump or fan are the corect one.The fan is easy to check just make sure its sucking the air in the right direction but the pump you might have to disconect a hose and start it to see if its pumping the right way.Also make sure the belt is installed properly because it can be wrong causing the pump and fan to spin the wrong direction.Come to think of it check the belt first.
     
  8. gmctrucks

    gmctrucks Full Member

    Joined:
    Nov 9, 2006
    Messages:
    7,525
    Likes Received:
    2,856
    Make sure they sold you the right pump is it pumping running in right direction is your 02 sensor connected see if you see the water flowing in radiator make sure you didn't put back the fan backwards maybe when you replaced the fan clutch you made a mistake and put it on backwards. What about taking off the top hose and see how the water is flowing just stick the water hose in the radiator when you testing it. Running it to 260' is to hot don't do that your taking years off the engine. If your going to buy a rad PM me I know of this site to order one cheap even the s/h is fair. Check evaporator and radiator fins are clogged with mud/bugs. Replace radiator cap make sure that the idler pulley is turning maybe it's frozen and the belt isn't turning enough. Check timing remember you need to disconnect wire by fire wall to set it right. Or cracked head this would be last thing to check the auto parts store has a kit to check if you have a cracked head. I hope this helps keep us up-dated.
     

Share This Page