4 wheel drive doesn't lock in

Discussion in 'GMC Truck Forum' started by bossdaddy, Nov 21, 2013.

  1. bossdaddy

    bossdaddy Member

    Joined:
    Nov 21, 2013
    Messages:
    8
    Likes Received:
    0
    I got a 1990 GMC 4x4 that I bought new and have maintained well thru the years. I used the 4 wheel drive about two weeks ago and it worked fine but three days ago I tried to lock it in and it wouldn't lock in. It has the shifter in the floor which is where the light is located letting you know it is locked in. The light don't work and the front wheels don't pull. I changed the acuator thinking it might be weak but it didn't fix the problem, also checked the new acuator before installing it and it checked OK. Anybody had this problem before, I need help.
     
  2. calisdad

    calisdad Full Member

    Joined:
    Oct 17, 2010
    Messages:
    151
    Likes Received:
    70
    I have a '96 that's push button and just had to change the shifter motor on the T-case. If yours is the same and you have to do this don't forget to disconnect the battery so the computer reboots.
     
    1 person likes this.
  3. MrMarty51

    MrMarty51 Full Member

    Joined:
    Aug 7, 2013
    Messages:
    6,655
    Likes Received:
    9,031
    Check the fuse.If the fuse is ok then, With a volt meter, ignition switch in the run position, engine off, shifter in 4 weeel drive mode, check the voltage at the connector that the actuator plugs into, should be near battery voltage, if no voltage is detected then let us know and We`ll give further instructions and I`d bet C.C. will have a wiring diagram, check to see if there is a relay in the system.
    By the way, My 93 K 1500 takes about a 1/2 a minute to a minute for the actuator to actually engage the front axle. Takes the heater that long to warm the pile and shove the actuator rod out, everything is new too. Including a complete rebuild of the right side axle.
     
    1 person likes this.
  4. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,672
    Likes Received:
    6,597
    there is a ball sensor on the transmission....jump it and see if it kicks in
     
    1 person likes this.
  5. batty1214

    batty1214 Senior Member

    Joined:
    Nov 2, 2008
    Messages:
    2,269
    Likes Received:
    494
    Unplug your actuator plug. Turn on your key, engine not running. Pull your transfercase into 4 wheel, and check for power at your plug. My 89 chef has had a bad wire in that circut several times. If your not getting power at the plug, chase it back to the transfercase switch. If it isn't sending out a signal, it could be faulty. Oh, I would suggest using a voltmeter to check for power, not your tongue....
     
    1 person likes this.
  6. MrMarty51

    MrMarty51 Full Member

    Joined:
    Aug 7, 2013
    Messages:
    6,655
    Likes Received:
    9,031
    :idea: Never, ever, ever stick Your tongue on a 6 volt drycell lantern battery,

    PLEASE DO NOT ASK ME HOW I KNOW THIS!!!!!!!!! :no: :help: :rofl:
     
    2 people like this.
  7. batty1214

    batty1214 Senior Member

    Joined:
    Nov 2, 2008
    Messages:
    2,269
    Likes Received:
    494
    :hah:
    This type of thing is why I included the don't use your tongue....:rofl:
     
    1 person likes this.
  8. MrMarty51

    MrMarty51 Full Member

    Joined:
    Aug 7, 2013
    Messages:
    6,655
    Likes Received:
    9,031
    6 volt lantern batree`ll knock Yuhr head offft, just sayin, I do`n even wanna knows what twelve`ll dooo.
    OK, tell Me. :rofl:

    We was taught by the older guys of the "HOOD" how to test a 9 volt transister {transisters was just beginning to be used} radio battreee by sticking them on the tongue, We could always tell by the amount of smoke and steam and by how many tastebuds it had destroyed, well, here is this old lantern/flashlight that`d been discarded by someone down the alley, it was in their garbage can so I "Kyped" { a very old word for lifted or stolen} it, got home and hiding behind the shed tried out My new "KYPED" flashing light, durn, it did`n ignite the bulb, and so a tear down and thorough investigation was in the wurks, by then a couple more of us "Island Rats" had gathered around, everyone seemd to know what the problem was and YES it would work if We would only try this way or that, according to the "pecking order" of the gang. Many things was tried and everything failed, Well, Maybe the battree is dead, and so I scooooped it off a the ground{ We must remember, this just come from a trash can, real types of rotting vegetation an such, not like fast foood wrapperz} and real brave like cause I knowd it was just dead and being only a 6 volt, not like a real battree, a 9 volt transister battree, I toucheded them two postestes to Mine toungue.
    I do`nt remember a thingk, except fur when I opened Mine eyes I was now laying back on the ground that I had been settingk on just a few seconts before and, what was that smell ??? OH yeah, the smell of ozone with a nice underlaying aroma of burnt flesh and sizzling tastebuds mixerd into the works. I think Mom must have thought I had "KYPED" some of dads Bull Durham and a coupleof papers and smoked a cigarette by the look on Her face when I come through the door, on my way to the bathroom to get a real visual of the extent of the damage to Mine tongue. Just could`nt trust the judgement of one of the guys from the hood, theyd say Its OK when the bone wuz a stickin out through the flesh so I had to do a personal investigation, nope, could`nt tell anything at all had happened except for that unforgettable stench that My nostrilz wuz full of.
     
  9. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,145
    Likes Received:
    12,671
  10. bossdaddy

    bossdaddy Member

    Joined:
    Nov 21, 2013
    Messages:
    8
    Likes Received:
    0
    Thanks guys for your interest. I checked the power when I replaced the acuator and power is good. The new acuator works fine, it's like it 's not ingaging right or not powerful enough. I don't know what the acuator ingages to inside the front end, maybe something is stuck inside the front end, electronicly everything seems to be working right, Help
     

Share This Page