86 K10 Exterior Light Wiring Diagram

Discussion in 'Chevy Truck Forum' started by Echo1, Jun 25, 2010.

  1. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    ive been able to find some diagrams, but im having trouble figuring out how to read it. i get the idea but i pretty much just need it dumbed down haha. if thats possible?
     

    Attached Files:

  2. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    i just need from the bulkhead connecter out. and i cant seem to find where that begins on the diagrams i found.

    also when i have the rear lights plugged in they come on when the headlights are off and vice versa. dont have a clue why because this wasnt happening when i took the truck apart. so for now i just removed the rear light harness until i figure out the headlights and everything else in the front. and the problem im having right now with the front lights is pretty inconsistent. the headlights come on sometimes. sometimes one comes on. when i put the brights on one comes, the other shuts off. the parking lights and side markers are dim or off inconsistently. its a mess. i cant figure out what the issue is when the problem is never the same.
     
  3. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    Second red flag guy to deal with today who's insisting on asking the wrong question.
    The other is my son. What happened to adapt and overcome ? :D

    You can't find the bulhead connection on those drawings because it's not there.
    Unfortunately what is often available for those trucks is multi year morphs.
    Think of them as concept drawings, not maps.
    You don't "need it dumbed down " any farther than it already is,
    unless someone can give me a good reason why the temp sensor
    is connected to the key. Your brain and eyes are more reliable imho.
    There are other errors in them I'm not even going to start on correcting.

    What exactly did you "take apart" relative to wiring ?
    Headlight switch wires removed ? Grounds around body ?
    Many of symptoms sound like poor/loose connections.
    You would probably save a lot of time using the wiggle test method.
    Seriously,
    hook stuff up and start wiggling the wires looking for changes in lights.

    Do it after a basic check for connections and shorts (2 min look-see)
    Make sure all the basic ground wires for frame and body are good.
    Here's a shorten and chopped version of your drawings.
    Front side markers are something I also question the accuracy of...
    If yours normally blink with turns, this drawing is wrong.

    Headlights & Parks are completely isolated from Stop & Turns if like drawing.
    If not, the only mix is front side markers, and removing those bulbs will isolate.

    Red dash circles are approximations of bulkhead connector.
    .
    [​IMG]
     

    Attached Files:

    Last edited: Jun 25, 2010
    Echo1 likes this.
  4. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    well i just took the harness out and unplugged lights etc.. thats why i dont understand whats wrong. did the wiggle test unknowingly the other day and lights would flicker, dim yada yada..

    adapt and overcome ended 3 weeks ago when i still wasnt getting anywhere lmao.

    but your drawing seems alot more straight forward and alot less of a headache than anything else i could find. ill start messing with things again and see how it goes.

    thanks a ton.
     
  5. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    No problem, happy to help if I can.

    If you are not blowing fuses and all lights come on at one point or another,
    then grounds and broken "travel" wires are not prime suspects.
    With headlights good when bulkhead connector for rear is disconnected,
    something at bulhead itself comes to mind. Inspect for dirt, bent contacts,
    loose contacts. Probing while testing can hurt connectors, bends them.

    Might also want to verify headlight switch is not bad by disconnecting
    and then using fused jumpers in its plug to run lights.
    Don't forget there for wiggles and that includes switch handle.
    What had you wiggled and got dimming on/at ?

    New sample philosohy: Nap and Undercome.
    Been in my brain since John Madden said one team underwelmed the other.
     
    Last edited: Jun 26, 2010
  6. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    so i went through and pretty much started from scratch on both harnesses (front and rear lights). someone before me got splice happy. after rewiring everything according to your diagram, i was able to get both headlights to work consistantly (high beams included), both parking lights in the front come on bright when the turn signal is on but only one actually blinks. the other is just solid. neither side markers will come on.

    with the blinkers on in the rear one tail light is on and actually blinks but on that side the small bulb wont come on. on the other side all the lights come on when the turn signal is on but theyre all dim. the reverse lights come on as they should. none of the rear lights come on when the headlights are on.

    thats how the day ended. tomorrow will be more tinkering. :rolleyes:
     
  7. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    found another diagram in a repair manual with a couple differences. the rear lights still look the same. but the front had some different wiring for the side markers. so hopefully that was the problem in the front.
     

    Attached Files:

    crabtruck likes this.
  8. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    140
    Good to see progress. :applaud:
    Your new draw has the correct wiring for blinking the sides.
    That is the item I mentioned above. In an unrelated(?) idea item,
    you could make that mod to the rear and have the sides blink back there as well.
    My draw did not include reverse since not through sw or arm,
    but them coming on indicates ground is likely good.

    Things to keep in mind:
    Turns won't blink if flasher does not blink.
    Flasher is less inclined to blink if load is too small, needs enough working bulbs.
    If hots are disconnected or grounds are bad or bulbs burnt or connections bad,
    all the same to the flasher. If bulhead apart, dash turn should be on.
    Cheap trick of switching bulbs side to side can catch some problems.

    "with the blinkers on in the rear one tail light is on "
    Hey ! Watch your language ! :D If true, that's a short in bulb or wire.
    Don't like the word "tail" because to some it's Park and others Stop/Turn.
    Tail typically means rear parking lamps, but people vary.
    For driver's back corner I prefer "LRpark" or "LRstop" as in LeftRear. :cool::)

    Truck this age there is no sub for following the ground from each rear lamp.
    They may have failing splices or even been re-routed from original design.
    You have the advantage of knowing the ground path from reverse is good.
    Suggest you remove all rear bulbs and grab an ohmmeter.
    The reverse lamp sockets should provide you with a handy ground contact.
    Check that each of the other sockets shows a good low resistance connection to ground.
    Inspect for any corrosion or looseness of contacts.
    Turn on park switch and use voltmeter to check rear sockets.
    Turn off parks and repeat with brake (preferred) or haz.
    If no volatge at rear for any of those, check for it at bulkhead,
    and if there, at connection under bed.

    This is cool. You're getting to know this setup so thoroughly
    that in the future I can refer all questions to you. :woot:
     
  9. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    well that turned out to be the problem in the front. didnt get a chance to check the rear yesterday. well see in a few hours. crossin my fingers.
     
  10. Echo1

    Echo1 Senior Member

    Joined:
    Mar 24, 2010
    Messages:
    145
    Likes Received:
    3
    turn signals work all around. reverse lights work. brake lights dont and when the lights turn on the stop/turn (haha) wont come on. im not sure if its the brake light switch? the one in this model is on the back side of the brake pedal. not sure how thats suppose to work?
     

Share This Page