89 chevy c1500 electrical issues

Discussion in 'Chevy Truck Forum' started by bergheger3, Aug 27, 2010.

  1. bergheger3

    bergheger3 Member

    Joined:
    Aug 27, 2010
    Messages:
    8
    Likes Received:
    0
    I am new to this forum and have been scanning the post a lot are similar to my issue but I have a few more problems going on, and I need some help.

    I have a 1989 Chevy C1500 2WD 350 with a 700R4. It all started a few days ago:

    Left turn signal would turn on the right side and right would turn on the left and all of the dash lights would blink with the turn signal. If I turn on the head lights I loose the turn signal and the brake lights. The break lights work with the headlights off. When the truck is warmed up the engine will die when at idle in drive and will stay running if in Nuetral or park. There are a few more issues but once this are fixed I will adress the others.

    I replaced the turnsignal cam and that fixed the blinking dash lights and the turn signals work correctly. The brake lights and turn signal still won't work when the head lights are on. The truck still dies as described above.

    So I have traced the grounds from the tail lights to the fire wall along the frame rail and everything looks good, I didn't unbolt and clean anything.

    I am now leaning towards a headlight switch but I am lost at this point. Any help would be greatly appreciated.
    Matt
     
  2. ETRNL

    ETRNL Senior Member

    Joined:
    May 6, 2010
    Messages:
    106
    Likes Received:
    1
    to me it sounds like you have a floating ground. u have it when the headlights are off but lose it when they are switched on. i would pull the switch and jump the terminals to see if the switch is bad. if not chech the ground at the dash support bar.
     
  3. bergheger3

    bergheger3 Member

    Joined:
    Aug 27, 2010
    Messages:
    8
    Likes Received:
    0
    I jumped the head light switch and the head lights work but no tail lights.

    When I press the brake everything goes haywire. Brake lights won;t work with head lights on, turn signals flash opposite whatthey are suppose to but work normally when brake pedal is released.

    I have been going through the wiring diagrams for the truck but I cannot find where the brake switch is connected into the tail light/headlight circuit but I would think it should be.

    Do you think the brake switch could be bad? How do I check it?

    Thanks
     
  4. ETRNL

    ETRNL Senior Member

    Joined:
    May 6, 2010
    Messages:
    106
    Likes Received:
    1
    remove it from the equation. pull the conector and jump the wires. while it is unhooked ohm the switch and post your findings
     
  5. bergheger3

    bergheger3 Member

    Joined:
    Aug 27, 2010
    Messages:
    8
    Likes Received:
    0
    I read .4 ohms when the switch is open and when the switch is closed.

    The turn signals work properly when the brake switch is disconnected.
     
  6. ETRNL

    ETRNL Senior Member

    Joined:
    May 6, 2010
    Messages:
    106
    Likes Received:
    1
    there you go. replace the switch
     
  7. Scr0ach

    Scr0ach Member

    Joined:
    Aug 28, 2010
    Messages:
    7
    Likes Received:
    0
    I had the exact same problem it ended up bein a crappy trailor lights ground
     
  8. bergheger3

    bergheger3 Member

    Joined:
    Aug 27, 2010
    Messages:
    8
    Likes Received:
    0
    Thanks guys got it fixed. It was the brake switch.

    Now to tackle the speeddo problem.
     

Share This Page