97 Chevy Pickup 5.7l sputtering and missing after warmup

Discussion in 'Chevy Truck Forum' started by daverol, Feb 28, 2012.

  1. daverol

    daverol New Member

    Joined:
    Feb 28, 2012
    Messages:
    4
    Likes Received:
    0
    About a week ago my pickup started sputtering and missing on light load after driving the vehicle for around 15-20 minutes. Replaced the Engine Heat Sensor because a mechanic friend of mine said this could cause the sputtering because of excessive fuel being fed to engine under light load. The engine runs great up to this point and even when you accelerate hard. Does anyone know what could cause this? I replaced the distributor about 4 months ago when it went out. I have currently 209,000 miles on this, but it has always been a great runner and dependable. Any help would be greatly appreciated.
     
  2. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,146
    Likes Received:
    12,679
    What is the heat sensor..talking about 02 sensor heater? Do you have a sel.service engine light? If so have scanned.
    Could be quite a few things ..try checking or changing the coolant temp senor located beside thermostat housing 10 bucks .
    Might be adding to much fuel.. at idle hesitations ..but uses extra fuel after acceleration.
    Hard to say with out a service light.
     
  3. daverol

    daverol New Member

    Joined:
    Feb 28, 2012
    Messages:
    4
    Likes Received:
    0
    Heat sensor is the coolant temp sensor. No SEL, no codes
     
  4. daverol

    daverol New Member

    Joined:
    Feb 28, 2012
    Messages:
    4
    Likes Received:
    0
    Could it be the IAC? I've heard it could be this too. Hard telling with no codes. I did have a 0141 O2 senor malfunction light last week, but has not come back on since re-setting
     
  5. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,146
    Likes Received:
    12,679
    Like said hard to tell ..no codes...i believe if it keeps doing this you will eventually get one.
    Seems if iacv would get a code. Maybe just low speed miss plugs or wires.. can have a high speed miss also.
    We do not want to keep guessing waste money. If not to bad run it should get a code.
     
  6. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    11,702
    Likes Received:
    6,637
    weak coil...bad wires?
     
  7. Sodell

    Sodell Senior Member

    Joined:
    Oct 17, 2011
    Messages:
    965
    Likes Received:
    384
    I would check (replace) the O2 Sensor, what your describing happened to me and I only got the check engine light a couple of times. The only reason I know this is because I accidently unhooked the O2 plug while doing some work on the engine. I usually learn by experience. I sounds like it only happens once it enters a closed loop.

    A code P0141 may mean that one or more of the following has happened:
    • open or short to ground in the wiring harness
    • O2 heater circuit wiring high resistance
    • O2 heater element resistance is high
    • Internal short or open in the heater element
     
  8. Chevy Man Larry

    Chevy Man Larry Member

    Joined:
    Feb 29, 2012
    Messages:
    5
    Likes Received:
    2
    Id check spark plugs for correct heat range>>could be heating up after driving awhile causing the sputtering.>>getting too hot & fouling out>>
     
  9. daverol

    daverol New Member

    Joined:
    Feb 28, 2012
    Messages:
    4
    Likes Received:
    0
    Well, went with your suggestion Sodell since I did have a 0141 code last week. So far (knock on wood) it seems to be running better. I drove it around last night for about a half hour and drove it to work this morning (about 20 mi.) and it has not acted up. (And it was no picnic getting to the 02 sensor to change) I do think I will go ahead and change out the plug wires and thermostat tonight also, since those weren't changed when I put the new distributor and plugs in it last summer. (Maybe a insurance policy?) I appreciate everyones input and will keep you guys informed if no more problems surface.
     
  10. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,146
    Likes Received:
    12,679
    Sodell getting to be a regular ole diagnostics man there. Glad it is running better ...keep us posted.
     

Share This Page