F250 speedo not working

Discussion in 'Ford Truck Forum' started by Robert78.5, Dec 4, 2009.

  1. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    98
    Likes Received:
    1
    We changed the sender unit on trans, now we changed the instrument cluster with a Ford rebuilt, still no speedometer. Where to look next? year 2000 automatic 2 wd gas,
     
  2. mrjohnwayne

    mrjohnwayne Full Member

    Joined:
    Apr 15, 2005
    Messages:
    4,062
    Likes Received:
    101
    vss on these trucks is located on the rearend. also doubles as the abs sensor.
     
  3. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    98
    Likes Received:
    1
    What does the sensor on transmission do than?
     
  4. davbell22602

    davbell22602 Senior Member

    Joined:
    Nov 11, 2009
    Messages:
    4,173
    Likes Received:
    23
    it sends a signal to the speedometer telling it how fast you are going.
     
  5. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    98
    Likes Received:
    1
    Thats what i figured but why does speedo not work?
     
  6. mrjohnwayne

    mrjohnwayne Full Member

    Joined:
    Apr 15, 2005
    Messages:
    4,062
    Likes Received:
    101
    the sensor on the tranny is also used as a speed measuring device... but the one that controls the speedo is on the pumpkin on the rearend. and I might have told you wrong. there might be 2 sensors on the rear end. depending if your truck is 2w abs or 4w abs.

    pretty sure you change the vss on the rearend and you'll get the speedo back.
     
    Case 7230 likes this.
  7. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    98
    Likes Received:
    1
    ok will try
     
  8. eponator

    eponator Senior Member

    Joined:
    Nov 26, 2008
    Messages:
    772
    Likes Received:
    11
    JW beat me to it, check your VSS on top of the rear diff facing the front of the truck. If you find allot of metal flakes or dirt / grime built up on the end of it then clean it up, stick it back in and go for a drive. Sometimes its just dirty and cleaning it will get you back on the road quickly.

    If this doesn't work then I'd replace it. Cheap part, simple fix, its pretty self explanatory.

    You mind me askin how much that recalibrated speedo set ya back?? OH and are you tripping any ABS lights?? Any codes being thrown?
     
  9. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    98
    Likes Received:
    1
    I changed it now it works. should have tried that before changing cluster,
     
    Last edited: Dec 9, 2009
  10. eponator

    eponator Senior Member

    Joined:
    Nov 26, 2008
    Messages:
    772
    Likes Received:
    11
    Glad we could help you get it working right again! Now, got any pics of that truck??

    :D
     

Share This Page