Izusu Rodeo '95 - Stalling/Acceleration Issues - After picking up from mechanic..

Discussion in 'Other Trucks' started by ckunzler84, Dec 31, 2014.

  1. ckunzler84

    ckunzler84 New Member

    Joined:
    Dec 31, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello, I will try to explain this best as possible. If anyone has a moment to read, my plea for help has never been greater. I need to get to the bottom of what happened to my truck =(

    -My '95 Rodeo has a rebuilt 4 cyclander engine with about 35k miles on it. about 220k miles on the vehicle. I change the oil often enough, as well have maintained it over the past 4 years.
    -The engine has always ran awesome.
    -Over the past 4 years, I've changed the starter twice, due to an issue of the vehicle having issues of not starting (Believed to be because of an alarm system that was taken out).
    -The starting issue returned, so I brought to a new mechanic to find the problem and fix it once and for all, electrical, whatever it was... Fix it. Sometimes it would start, other times the starter wouldn't engane and just click (not turn, just click).
    -----------------------------------------
    -So while my truck is at this shop, I have them change the oil, replace the shocks.
    -As well I wanted them to fix the backup lights (the while lights while reversing).
    -They held my vehicle for 4 weeks (2nd week because they first ordered the wrong reverse light switch. 3rd week the switch didn't fit even though it was from a junkyard 95 rodeo. 4th week they called saying that they found the right switch online and when they tried it, they came to find:
    Something about a rod that could drop into the transmission and destroy it if they changed the reverse light switch or something along those lines...)
    ------------------------------------
    -So I pick up the vehicle, I wash it, fill it with gas, and about 5 minutes from home the vehicle starts bucking and accelerating at 30mph in 3rd gear is normal for me.. it was bucking hard, I had to go to 2nd and be easy.
    -I thought to myself, maybe it was bad gas or water in the gas.
    -Over the next week I put Sea Foam to remove water/clean injectors, burn the tank of gas up, and filled up with new gas and still the vehicle was bucking during a harder accelleration (30mph in 4th gear, I used to be able to floor it as an example, now it bucks and I have to change to 3rd gear and rev it a bit). During this week the vehicle stalled out on me during accelerations in a lower gear, and had a hard time starting for a few minutes. It would choke and sputter me home for 20 minutes after stalling. Having to rev it not too hard, but it would bucked and start to stall while releasing the clutch pedal.
    ------------------------------------------------------------------------------
    -So as I said I had this shop change the oil, well after a week went by dealing with bucking and thinking it was water in the gas tank, I check the oil filter, and it's the same one from 6 months ago, it was a Quart low on oil and the oil in there was black and bubbly.
    -I brought it back to them, they changed the oil, said they flushed it a bit, and put on a new filter.
    -My friend picked it up and she drives like 114 year old sooo, I drove it today and 30mph in 4th gear, it bucks and about stalls when I accellerate.
    -As well I smell gasoline fumes and have since I picked it up from that shop the first time.
    -Also the engine feels like it's misfiring randomly and not running smooth.

    The vehicle was really awesome for 4 years except for the starting issue randomly, and all of a sudden this??


    Thanks so much for reading this and I hope you can assist me =)
     
  2. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,361
    Likes Received:
    7,451
    Trophy Points:
    113
    Location:
    N.Y.
    sounds like the first thing you should do is find a better shop to do your work,
     
    1 person likes this.
  3. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,215
    Likes Received:
    12,855
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Why would they keep your vehicle..let you have it till part comes in? One thing at least learned from this don,t go back to that garage!!
    They probably s crewed it up on purpose to get you back $$$$$$$
     
  4. BurbanMan

    BurbanMan Full Member

    Joined:
    Jul 22, 2014
    Messages:
    1,225
    Likes Received:
    987
    Trophy Points:
    113
    Occupation:
    Stove tech @ true value
    Location:
    Cortez, CO
    Do you have a check engine light on? sounds like its getting too much fuel. If the fuel pressure regulator is outside the intake, take the vacuum line off of it and see if it drips fuel or appears moist/damp. That would tell you if the regulator has failed. Without having you do some diagnostic work and reporting back to us every 10 minutes or so, it will be hard to help you find out what is wrong.
     
    2 people like this.

Share This Page