Trans Fault Message For 2005 F-150

Discussion in 'Ford Truck Forum' started by LDH Constr, Feb 24, 2012.

  1. LDH Constr

    LDH Constr New Member

    Joined:
    Feb 24, 2012
    Messages:
    2
    Likes Received:
    0
    I havent driven my 2005 F150 in a week. drove it today and got a blinking o/d light and a trans Fault message in the odometer area. The truck ran fine last time I drove it. Just had all of the plugs and (1) Seliniod replaced 2 months ago. the truck has 119000 miles on it. I dont haul anything or go off road. I use 4x4 very rearly. The overdrive doesnt seem to kick in. seem to stay in 1 or 2 gear with high rpms when the accellarator is pressed.
     
    Last edited: Feb 24, 2012
  2. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,147
    Likes Received:
    12,690
    What was the code? Sounds like in limp mode od flashing..not much on ford ...but do you have the code number?
     
  3. LDH Constr

    LDH Constr New Member

    Joined:
    Feb 24, 2012
    Messages:
    2
    Likes Received:
    0
    There was no code number flashing, read that it could be, I think it was called TCC seliniod
     
  4. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,147
    Likes Received:
    12,690
    There are other components..that work with the tcc. Need to have it scanned ..so you want waste money and time.
    If light is flashing do not drive till you get fixed ..The light is telling you a problem is present please scan will lead you to problem.
     
  5. Case 7230

    Case 7230 Senior Member

    Joined:
    Dec 15, 2007
    Messages:
    1,645
    Likes Received:
    53
    cc is right, you need to take it to a good trans shop and let them check it for trouble codes.
     
  6. chevychase

    chevychase Senior Moderator Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,147
    Likes Received:
    12,690
    Done a little search on flashing light trans has gone in safe mode ..will not shift pass 2nd limp you home mode.
    Most times it is trans temp to hot...might need filter and fluid change and could be a bad temp switch.
    Why you need a scan. Could be trans gone bad.
     

Share This Page