2000 GMC Yukon Service 4WD Light

Discussion in 'GMC Truck Forum' started by SQBADOG, Oct 21, 2010.

  1. SQBADOG

    SQBADOG Full Member

    Joined:
    Jun 1, 2010
    Messages:
    313
    Likes Received:
    130
    Trophy Points:
    43
    Occupation:
    Healthcare...or whats about to be whats left of it
    Location:
    City of Brotherly Hoods.
    #1 SQBADOG, Oct 21, 2010
    Last edited by a moderator: Apr 19, 2011
    I have a 2000 Yukon XL with 153k. It has the 5.3 Vortec. Great running truck.

    On the way home last night, the 'Service 4WD' light came on.
    I checked the manual, it said that there could be a problem...nice.
    Did a search of the forum, did not see anything posted.

    Truck is a family mobile, not used hard, highway miles.
    Changed rear diff fluid 10k ago because the pan had started to rust thorough and was wet.:confused:
     
  2. 87c10slammer

    87c10slammer Senior Member

    Joined:
    Mar 20, 2008
    Messages:
    3,221
    Likes Received:
    49
    Trophy Points:
    0
    Occupation:
    factory worker making a/c and heating units.
    Location:
    levittown pa
    its probley your transfer case oil. your suppose to service it every 100k and they make trucks so smart that it knows when the oil is breaking down.
     
  3. cannedham1

    cannedham1 Full Member

    Joined:
    Jun 29, 2009
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    0
    4wd light

    I had the same problem last year . It was the wire harness under the hood. The dealer said water had got into it and corroded the connection.
     
  4. SQBADOG

    SQBADOG Full Member

    Joined:
    Jun 1, 2010
    Messages:
    313
    Likes Received:
    130
    Trophy Points:
    43
    Occupation:
    Healthcare...or whats about to be whats left of it
    Location:
    City of Brotherly Hoods.
    I actually did that service.

    Wonder if it generates a code.

    Read that the transfer switch is really common. Hmmmmm
     
  5. 99-GMCSierraZ71

    99-GMCSierraZ71 Full Member

    Joined:
    Oct 20, 2009
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Nanaimo BC Canada
    I had that light come on, I ended up having to replace the switch cause everything was working OK

    I'm not sure what you call it but its the electronic switch on the dash you push when you want to change it from 2 wheel drive to 4 wheel

    Cost me 50 bucks...fixed
     
  6. SQBADOG

    SQBADOG Full Member

    Joined:
    Jun 1, 2010
    Messages:
    313
    Likes Received:
    130
    Trophy Points:
    43
    Occupation:
    Healthcare...or whats about to be whats left of it
    Location:
    City of Brotherly Hoods.
    It was the switch. Technical bulletin issued.
     
  7. crabtruck

    crabtruck Senior Member

    Joined:
    Jul 9, 2007
    Messages:
    5,566
    Likes Received:
    142
    Trophy Points:
    0
    Thanks for the update, glad to hear it's fixed.

    Had looked before and missed this TSB
    Did you ever have codes read, get a B2725 ?
    .
    1999-2002-GM-Sev4WD-dtcB2725-Tcase-Sw-.jpg
     

Share This Page