The Truck Forum is Back!

Discussion in 'Forum Help' started by admin, Mar 5, 2014.

  1. admin

    admin Administrator
    Staff Member

    Joined:
    Jul 15, 2004
    Messages:
    624
    Likes Received:
    151
    Trophy Points:
    43
    #1 admin, Mar 5, 2014
    Last edited: Mar 5, 2014
    :mtruck:Yes, Our Truck Forum is back!!! :mtruck:
    One of the longest down-times in our history (48 hours) is finally over.

    The cause?
    Catastrophic server hardware failure & data corruption.

    The solution?
    2.5 days of working straight with about 4 hours of sleep.
    Brand New server
    A new, much stronger security system
    Off-site backup Recovery.

    The Effect?
    We'll be limping for the next few days. Expect some slowness for a few days. Lots of little forum features are missing, search is down, the forum is generic looking, etc. I expect some issues with the new security system/upgrade, so do PM or post about errors you receive or blank pages. For the time being I would probably copy any paste before you hit send, just in case. More importantly, we've lost a day and a couple hours of posts, PMs & pictures. I tried really hard to recover them, which only extended the downtime. In hindsight, I probably should have just gone with the backup. Some of you managed to post yesterday in the couple hours we were limping along. Unfortunately anything posted on March 3rd and the couple hours we were up on the 4th is gone. My apologies. But thank heaven the last 10 years of posts are still here and we only lost a day's worth.

    What's NexT?
    Since the goal was to recover the data and get us back up, you can see we're running a plain vanilla version of the truck forum. What comes next is an awesome an accelerated update. Including new classifieds, new forum sections, product reviews, a nicer theme and more useful mobile theme. These will be implemented MUCH faster due to what happened, so at least there is that bright side.

    Welcome back everyone!


    PS: You can reply >here< in the forum help section.
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,483
    Likes Received:
    13,306
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    #2 chevychase, Mar 5, 2014
    Last edited by a moderator: Mar 5, 2014
    Great work Victor. It is a lot to keep these forums running smooth. Now you need to get some needed rest for sure.
    We will watch for glitches ect. I get this at profile??
    (error when viewing likes removed)
     
  3. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,813
    Likes Received:
    7,967
    Trophy Points:
    113
    Location:
    N.Y.
    thanks for the hard work!...wondered what happened, was afraid it was hacked,....a lot of history here, 1 day lost is is not so bad as the other possibilities
     
    1 person likes this.
  4. Boudin

    Boudin Forum Moderator

    Joined:
    Jul 19, 2009
    Messages:
    4,456
    Likes Received:
    602
    Trophy Points:
    0
    Occupation:
    Jack of all trades, master of none
    Location:
    Central Mississippi
    You certainly got that right. It's been down for 2.5 days. I had withdrawals and was "jonesing". lol.
     
    1 person likes this.
  5. MikeG

    MikeG Full Member

    Joined:
    Feb 26, 2011
    Messages:
    2,972
    Likes Received:
    2,223
    Trophy Points:
    113
    Occupation:
    Wind Turbine Technician
    Location:
    Richland, WA GMTruckClub.com
    I second that!! I was trying every 30min to see if it was on my end or hoping it would reappear. I WAS NEEDING MY FIX MAN!!!!! :rofl::rofl:

    Thank you Admin for all the hard work to get us up and running again; also for all the work you do daily (that we don't see) on this awesome forum! :bow:
     
    1 person likes this.
  6. admin

    admin Administrator
    Staff Member

    Joined:
    Jul 15, 2004
    Messages:
    624
    Likes Received:
    151
    Trophy Points:
    43
    So you were the ones that the firewall thought was attempting a DOS (Denial of Service) attack. :)

    I'm aware of the warning error that pops appears when you view your "likes." Working on it. I removed the error from the post so it doesn't show up in search engines (it's fine to post it one so I can see it and copy it down).
     
    2 people like this.
  7. dirtrider73068

    dirtrider73068 Senior Moderator
    Staff Member

    Joined:
    Jul 14, 2011
    Messages:
    6,956
    Likes Received:
    4,474
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    dump trucker driver
    Location:
    Central Oklahoma
    A few times tonight I got a connection timed out, could wait a bit it would then connect to the site. Thought admin was working on it.
     
  8. MikeG

    MikeG Full Member

    Joined:
    Feb 26, 2011
    Messages:
    2,972
    Likes Received:
    2,223
    Trophy Points:
    113
    Occupation:
    Wind Turbine Technician
    Location:
    Richland, WA GMTruckClub.com

    YOU GOT ME! You caught the 'Tater!!! :rofl::rofl:
     
    1 person likes this.
  9. admin

    admin Administrator
    Staff Member

    Joined:
    Jul 15, 2004
    Messages:
    624
    Likes Received:
    151
    Trophy Points:
    43
    Most of the warning messages should be fixed. Also the multi-picture uploader should be working. If it isn't, please clear your browser cache, cookies and restart. If it's still an issue, please let me know.
     
    1 person likes this.
  10. gmctrucks

    gmctrucks Full Member

    Joined:
    Nov 9, 2006
    Messages:
    9,240
    Likes Received:
    4,961
    Trophy Points:
    113
    Location:
    Houston,Texas
    Thank you so much for your hard work I was getting the shakes.
     
    1 person likes this.

Share This Page